Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 64 bit default & shortcut conflicts

  • 9 uphendule
  • 1 inale nkinga
  • 138 views
  • Igcine ukuphendulwa ngu jpjrsf

more options

Windows 10 update: Existing FF shortcut is not default (that can not be changed) and new FF shortcut is required default but will not launch with open tabs and book marks as older shortcut.

Windows update mess: Totally confusing. I am on a 64 bit lap top.

Conflict: Two FF shortcuts launch the same 64 bit version of FF from two different start directories but only the old one retains my book marks or open research tabs. Launch that and I get error 'not the default browser" and that can not be changed. Launch FF from any web link or email and same 64 bit program launches with no open tabs or book marks. Can not set old (BEST) shortcut as the default it always previously was.

First: After a recent Windows 10 upgrade, when I now launch the Firefox from the icon shortcut pinned to my task bar, it now says “Firefox is not your default browser” and I am given the choice to use FF as my default browser. But no matter what I do I can not stop that default browser error AND Windows tells me the FF IS selected as the default.

The properties of the Original shortcut on my task bar short cut are”

Target: "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" Start in "C:\Program Files (x86)\Mozilla Firefox"

Ths is puzzling for that appears to be correct for 32 bit and not 64 bit program. I have ALWAYS been using that shortcut for years not with no problem. I prefer to keep that because I currently have about 25 open tabs for a research project and dozens of favorites in my tool bar. That is what launched whenever I clicked a link in my email or in any web document. BUT not any more!

Second: Since the Win 10 upgrade, even if the original shortcut is open, if I click on a link in my email or any web site, FF does not launch in a new tab from with that launched shortcut and opened FF page but instead opens a new window. In that instance I do not get the message "Fire Fox is not your default browser” of in that instance it IS my default! But I am getting an entirely different FF page: no open tabs and no bookmarks.

As I sleuthed about I discover that from any emial or a web link FF is not launching from that original task bar shortcut but different a different shortcut new to my desk top which has the same properties as the FF in my list of programs . The properties of those shortcuts are:

NEW Shortcut: Target "C:\Program Files\Mozilla Firefox\firefox.exe" Start in "C:\Program Files\Mozilla Firefox"

It does not appear that I am running two versions of FF. No matter which shortcut I launch About FF tells me I am running FF version 85.0.2 (65 bit) so there even though it is launched from a different “Start” location.

So the new shortcut after Win 10 upgrade launches FF version 85.0.2 (65 bit) from Target "C:\Program Files\Mozilla Firefox\firefox.exe" with no open tabs and no Book marks and appears to be the dafault

And the OLD preferred shortcut launches FF version 85.0.2 (65 bit) from Target: "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" (which should have been reserve for 32 bit?) and that shortcut launch tells me FF is not my default browner however but it IS the default as launched from Target "C:\Program Files\Mozilla Firefox\firefox.exe"

This may explain why the original old shortcut tells me FF is not my default browser and I can not change it since that already is selected as the default in the new shortcut. It may also expiation why launching from the new shortcut does not me give me that error.

Maddening! What do I do? I dare not uninstall FF because there is apparently only one 64 bit version running.

If I change the NEW shortcut properties so the same as the old original shortcut properties that does not help. Widows still insists that FF Target "C:\Program Files\Mozilla Firefox\firefox.exe" is/must the default and I can not modify that in path in programs and apps.

Windows seems to insist that FF can only be the default if lanced from "C:\Program Files\Mozilla Firefox\firefox.exe". A launch from "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" will insostg it is not the default and I can not change that.

So how to I get FF version 85.0.2 (65 bit) to launch from Target "C:\Program Files\Mozilla Firefox\firefox.exe" BUT with all the open tabs and book marks it launches from Target: "C:\Program Files (x86)\Mozilla Firefox\firefox.exe"

I think this means Windows 10 will no longer allow FF to be the default if launched from "C:\Program Files (x86)\Mozilla Firefox\firefox.exe"

As far as email or web links I can not make FF to launch from "C:\Program Files (x86)\Mozilla Firefox\firefox.exe".

So, somehow we I must accept Target "C:\Program Files\Mozilla Firefox\firefox.exe" as the default path. So how do I import all my open tabs and book marks into the FF that launches from Target "C:\Program Files\Mozilla Firefox\firefox.exe"

Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

I think you can remove

C:\Program Files (x86)\Mozilla Firefox

but you could test the theory by renaming it to

C:\Program Files (x86)\OldFirefox

and monitoring for a few days. If there are no objections by other programs, you could dump the folder.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (9)

more options

Let me start by saying: before Firefox converted users of 32-bit Firefox to 64-bit Firefox, of course 32-bit Firefox was installed into the Program Files (x86) directory like other 32-bit programs. When Firefox converted (around the days of Firefox 54), it kept using that same folder for upgrades. Over the past year, a number of users have had an upgrade glitch that created a new installation in the regular Program Files folder used for 64-bit programs, resulting in a dual install. So we have an idea of how to sort this out.

The first thing to try is switching your newer installation to using a different profile. Here's how:

Make sure your older installation is not running. Launch your newer installation, and then:

Version Check

You already confirmed that your newer install is 85.0.2, the latest release, so Firefox shouldn't raise any objections about switching profiles.

Profile Manager Page

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

This page should list at least two profiles and could list many. (Each profile has two folders and one or more buttons. Do not use any Remove buttons!)

The profile that Firefox is currently using will have this:

This is the profile in use and it cannot be deleted.

This is the profile that doesn't have your data.

For the other profile (or one of the other profiles), check whether it is the one you prefer by clicking its Launch profile in new browser button.

If it isn't what you want, simply close that new window.

If it IS what you want, back on the about:profiles page, click the Set as default profile button for that profile so Firefox uses it automatically at the next startup.

Exit Firefox and restart your newer installation. Did it work?


Now, how to get rid of the unnecessary Program Files (x86) installation without doing any damage. Let's return to that after fixing the profile issue.

Helpful?

more options

Thank you but I think you are missing the point or I am confused. Define “installation” . There is no second “installation” – if only that was the problem. There is only one FF in the programs list. Are you saying that FF is separately installed in two different directories (the new blank one being the unchangeable FF default and the other being the preferred x86 directory?

Helpful?

more options

OMG! YES! That worked! U R A CHAMP! Superbly communicated! Now then what should I delete from where? I presume I should delete the old short cut pinned to the task bar? And what else should I delete or uninstall and how? I presume all Mozilla in the x86 related directories? Again thank you! What a relief! Please advise as to clean up.

And, oh yes, will this effect any of my add-ons and plug ins?

Helpful?

more options

So far, so good.

Yes, change your shortcut.

Do you have Microsoft Office on your computer? If so, click a link in Word or Outlook to make sure it is opening the correct Firefox. It can be the most stubborn app when it comes to changes of default browser.

If that isn't a factor, you can delete the old Firefox installation under Program Files (x86) so it can't accidentally run again. It would be extremely unusual to be running add-ons from that folder which aren't part of Firefox's own installation. However, if you remember ever creating Autoconfig files (like mozilla.cfg) or a policies.json file in this older Firefox program folder, you may want to rescue those before deleting.

Helpful?

more options

Thanks again. No I do not have Outlook or MS Office and the new FF launches fine from links in Word Perfect (Corel) and Windows Live mail (WLM). I just deleted the old FF shortcut form the task bar and re-pinned the new one. It’s all good! I do not recall creating any .cfg files. Not sure what x86 files you want me to delete. Can you be more specific.

BTW (if it falls within your expertise) the same Win 10 upgrade caused a problem in WLM. I receive mail all just fine and links work but I can sent or reply. “A problem occurred opening this file....” WLM was working just fine in Win 10 till this update and, of course, Microsoft will provide no support and, given the level of support I’ve gotten for Win 10 they are, quite frankly, a disgrace. I want to avoid buying Office or Outlook! So if you know a fix that would be great but please clarify what you suggest me to delete from the C:\Program Files (x86). There is an ‘uninstall’ there but I presume that should be avoided. Do I delete all Mozilla related files from that directory?

Again, tank you VERY much. SO appreciative!!!!!

Helpful?

more options

Isisombululo Esikhethiwe

I think you can remove

C:\Program Files (x86)\Mozilla Firefox

but you could test the theory by renaming it to

C:\Program Files (x86)\OldFirefox

and monitoring for a few days. If there are no objections by other programs, you could dump the folder.

Helpful?

more options

Will do. Thank you again... very much.

Btw: Mozilla Thunderbird and Mozilla Maintenance Service are also in the Program Files (x86) directory. I do use Thunderbird. Does the FF issue portend similar problems with Thunderbird? And since I have a 64 bit commuter do I really need the x86 directory at all since that’s for 32 bit computers?

Helpful?

more options

I have not heard of any double-install issues with the maintenance service or with Thunderbird. There definitely are a lot of 32-bit programs that all of us 64-bit Windows users still rely on, so I wouldn't delete anything else there.

Helpful?

more options

Thanks again! All seems good!

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.