Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Why can't I hear a thing when I play youtube via Firefox?

  • 2 uphendule
  • 1 inale nkinga
  • 485 views
  • Igcine ukuphendulwa ngu dismlz

more options

Here are some tricky parts:

1) When using Firefox, take YouTube video as an example, I can hear the music if I connect my laptop to an external Bluetooth speaker. (But without using a Bluetooth speaker or any external speaker, there is no sound through my laptop even thought I turn my laptop volume to the greatest.)

2) For the same video, if I use google chrome, I have no problem hear the music no matter using a Bluetooth speaker or my laptop internal speaker.

3) You can argue my Firefox privacy Autoplay setting was wrong. But I checked and I allow both audio and video for all websites. Besides, I also checked the Permissions status on each website.

4) The weirdest part I don't get: Supposedly I can play and hear sound through Firefox, since I authorize all the website. But why there is no sound if I'm using my laptop's internal speaker? ( And only the laptop's internal speaker)

5) For my internal speaker, it work fine when I use Zoom, hear music through windows' Groove player, or even play video through Chrome.

Last but not least, I still ran troubleshooting trying to fix my internal speaker. But they can't detect any problem.

I'm so confused.... Does firefox hate my laptops internal speaker? Please help me. Thanks

Isisombululo esikhethiwe

Check your playback device. Can you right click on the speaker and open the mixer?

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (2)

more options

Isisombululo Esikhethiwe

Check your playback device. Can you right click on the speaker and open the mixer?

Okulungisiwe ngu jonzn4SUSE

more options

Oh my goodness! That was the problem! Thank you for much for helping!