Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox doesn't open some pages, where i can open them on internet explorer and chrome

  • 2 uphendule
  • 1 inale nkinga
  • 28 views
  • Igcine ukuphendulwa ngu ahmed.elghoul

more options
i couldn't see the mozilla survey using firefox, i opened it using internet explorer https://qsurvey.mozilla.com/s3/daily-attitude-survey?fxVersion=85.0&isDefaultBrowser=0&searchEngine=google-b-d&source=heartbeat&surveyversion=85.0&syncSetup=0&updateChannel=release&utm_campaign=PleasehelpmakeFirefoxbetterbytakingthisshort3-questionsurvey&utm_medium=show-heartbeat&utm_source=firefox&userId=6ad9d740-93c9-4570-9140-390a8f1d4328&type=button&flowId=1c17bfdd-0883-48d9-bc75-46cfab567180 also, this web page doesn't work properly, i can't see the wheather devolopment https://www.windy.com/ thank you for your help
Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

Hi, try turning off 'Enhanced Tracking Protection' for that site by clicking the shield icon at the left-hand end of the address bar while the page is loaded - Enhanced Tracking Protection in Firefox for desktop.

If that doesn't help, disable any ad blocker you may be using then reload the site.


Hold down the Shift key when you start Firefox to start in Safe Mode. More - Diagnose Firefox issues using Troubleshoot Mode.

If it works in Safe Mode, disable any extensions you have - 3-bar menu > Add-ons > Extensions, then restart Firefox; now if it's still OK, re-enable them one by one until you find the culprit. You may need to restart Firefox after enabling some extensions.

If your question is resolved by this or another answer, please help other users by marking the best reply as Solved. Thank you!

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (2)

more options

Isisombululo Esikhethiwe

Hi, try turning off 'Enhanced Tracking Protection' for that site by clicking the shield icon at the left-hand end of the address bar while the page is loaded - Enhanced Tracking Protection in Firefox for desktop.

If that doesn't help, disable any ad blocker you may be using then reload the site.


Hold down the Shift key when you start Firefox to start in Safe Mode. More - Diagnose Firefox issues using Troubleshoot Mode.

If it works in Safe Mode, disable any extensions you have - 3-bar menu > Add-ons > Extensions, then restart Firefox; now if it's still OK, re-enable them one by one until you find the culprit. You may need to restart Firefox after enabling some extensions.

If your question is resolved by this or another answer, please help other users by marking the best reply as Solved. Thank you!

more options

Hello, and thank you for your support!

unfortunatly both actions didn't help

Okulungisiwe ngu ahmed.elghoul