Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Autoplay Disabled but Some Videos Still Autoplay

  • 4 uphendule
  • 1 inale nkinga
  • 114 views
  • Igcine ukuphendulwa ngu Rob

more options

I have disabled autoplay in my preferences for all websites, but some videos on some websites still autoplay. (This is under Preferences / Privacy and Security / Autoplay. Under "Default for all Websites", it is set to Block Audio and Video.) How is it that some websites are able to get around this? Is there a way to defeat them?

I have disabled autoplay in my preferences for all websites, but some videos on some websites still autoplay. (This is under Preferences / Privacy and Security / Autoplay. Under "Default for all Websites", it is set to Block Audio and Video.) How is it that some websites are able to get around this? Is there a way to defeat them?

All Replies (4)

more options

How about trying the same process in a new version of Firefox.

https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

Can you provide the site that auto plays for you?

more options

You can look at these prefs on the the about:config page to see what settings work for you to block autoplay.

  • media.autoplay.default = 5 [0:allow;1:blockAudible;2:Prompt;5:blockAll]
  • media.autoplay.blocking_policy = 2
  • media.autoplay.allow-extension-background-pages = false
  • media.autoplay.block-event.enabled = true

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.


more options

jonzn4SUSE and cor-el: thanks for the replies. To answer your questions:

1. According to About Firefox, my version is up to date. It is 78.6.1esr. 2. One site that autoplays videos, despite my settings, is www.espn.com/nba 3. My about:config settings (after a search for "autoplay" are currently set to:

dom.media.autoplay.autoplay-policy-api false media.autoplay.allow-extension-background-pages true media.autoplay.block-event.enabled false media.autoplay.block-webaudio false media.autoplay.blocking_policy 0 media.autoplay.default 5 media.autoplay.enabled false media.block-autoplay-until-in-foreground true media.geckoview.autoplay.request false media.geckoview.autoplay.request.testing 0 services.sync.prefs.sync.media.autoplay.default true

Cor-el recommended:

   media.autoplay.default = 5 [0:allow;1:blockAudible;2:Prompt;5:blockAll]    SAME AS MINE
   media.autoplay.blocking_policy = 2                                           MINE IS 0.  SHOULD I CHANGE?
   media.autoplay.allow-extension-background-pages = false         MINE IS TRUE. SHOULD I CHANGE?
   media.autoplay.block-event.enabled = true                             MINE IS FALSE.  SHOULD I CHANGE?

Thanks for the help.

more options

After posting the details (see above), anybody got any suggestions?