Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Spacing line & changing font size by it self

  • 10 uphendule
  • 1 inale nkinga
  • 161 views
  • Igcine ukuphendulwa ngu o.larsen1

more options

Why does vers. 78.6.1 insist on double spacing, I have tried different settings and searched for solutions (It is not just when answering a mail) with no luck. More annoying than this is that when answering mail (and sometimes even when I start a new mail), it for some reason likes to change font size to medium, and I have configured it to large (I often have to keep doing this over and over) I have, like with the former problem, searched for solutions for this for hours, and I can see that this has been an ongoing problem, but I will ask again: why cant there be a simple solution to this so that one can choose ONE font, ONE size that are kept ALL the time. I don't need my font to adapt to other fonts that are in the mail that I am answering, quite opposite, I want what I write to always stand out from the font in the mail that I am answering. (I know that I can shift to plain text, as somebody suggested, but then it also changes mail i receive to plain text and removes pictures, layout etc.)

Okulungisiwe ngu o.larsen1

Isisombululo esikhethiwe

I set up my system like yours to test. I managed to reproduce some alteration in size as yourself and also a font alteration.

This anomaly occured because I needed to set up the 'Fonts for' 'Other Writing systems' see attached image. There was a disparity in the settings. The 'Latin' said size was 16, but the 'Other Writing Systems' was set up with a different font and size. So if doing anything for 'Latin', make the changes and click on OK Then go back and repeat for other 'Fonts for': settings After doing the 'Other Writing Systems' setting click on OK which does close the window. then click on 'Advanced' to open again to check for any other 'Fonts for' setting. I'm not sure if any other 'Fonts for:' options would effect you.

I would also advise you change the minimum font to 14 or 16 as well, unless you want Thunderbird to allow senders to display a small font or indeed you yourself may want to use something smaller. But size 10 pixel is quite small if you are accustomed to 16.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (10)

more options

'Double spacing' is paragraph mode by default which is set up here:

  • Menu app icon > Options
  • Select 'Composition'
  • Scroll to 'HTML Style' section
  • Uncheck checkbox: 'Use paragraph format instead of body text by default' - Do not select this option to force 'Body Text' to be default'

This will then work on a the next Write window opened, but not in any Write windows you had already opened before changing the setting.


re: why cant there be a simple solution to this so that one can choose ONE font, ONE size that are kept ALL the time. It is very easy to preset one font and one font size as your default and that would work in a new Write email. It will also work in any 'Reply' that does not contain any preset html css that effects the font and or font-size.

If you are 'replying' to an email, the entire contents of that original email are copied over to a new 'Write' message, allowing you to add comments to that original email either above or to make comments in specific locations within the original content. When I say 'copied all the contents' that means everything. It is not just the text, but also all the html css that was used in the original email.

If the sender of the original email created that email using html css that preset the font, font-size. paragraph format etc, this means whatever you now type into that email, it will be forced to use the html css information already within that email. Therefore you would need to type content, then highlight that content and select a larger font-size because you want to 'Edit' the html css the original sender specifically preset. It is a real nuisance when people create emails that include html css that force certain conditions like font size.

This explains why you experience that 'font-size' issue when you are using the identical html css code preset in the original email. As you point out "I know that I can shift to plain text...but then it also changes mail i receive to plain text and removes pictures, layout etc." - yes and that works because all the preset formatting is completely removed.

Helpful?

more options

Font -Size: You need to understand there is a difference between what you want to see when reading and composing emails and what the recipient of your email will want to see.

Generally, it is not a good idea to force font-size on people because we all have different eyesight preferences. That's why Thunderbird uses the options 'Tiny, small, medium, large, extra large and huge'. They are not size specific. Medium on your computer may be Size 16, but on your recipients computer medium might be size 12. But both you and recipient are happy.

So, you can use large and extra large for various headers and medium for general content. This means the email can look composed correctly. When the recipient reads it, generally it will still appear well composed, but the actual size of font will depend upon their settings.

  • Menu app icon > Options
  • select 'General'
  • scroll to 'Language & appearance' section
  • Set default font eg: Arial
  • Set default size eg: 14
  • click on 'Advanced' button to open the 'Fonts & encodings' window.

'Fonts for: eg: Latin You will notice the 'Proportional font size is 14 - same as whatever was set as default size. This becomes your 'Medium' setting. There will also be a 'Minimum Font Size' option. If you also set that to be size 14, you will be forcing all 'tiny and small' font settings to appear as if the same size as the default medium'. Setting a smaller minimum font size, will allow small and tiny depending upon your minimum setting.

I prefer to try to keep all to the same font, so if you would like this:

  • uncheck 'Allow messages to use other fonts'

It is also useful to check the another 'Fonts for: setting. So use the drop down and select 'Other Writing Systems' - usually located near the botton of list. Then also set same font sizes etc.

Click on 'OK'


  • Menu app icon > Options
  • select 'Composition'
  • Under 'HTML Style' section

Ideally use the default setting: It will adopt the 'size' setting you set up as per info above.

  • Font: Variable width
  • Size: Medium

This basically means you have set to use a 'medium' which is a larger font size for your viewing. But, you have sent email with a 'medium' setting' so when the recipient reads it, it will use whatever the recipient has set up as their 'medium' font. Both parties are happy.


Just to show you what I mean by how the 'minimum' font size can be controlled. The image below shows : on left side default proportional font was 14 and minimum font was 10. on the right side default proportional font was 14 and minimum font was also 14. Note how by changing the minimum font to same as proportional font size, the tiny and small font size selection appears to be the same as the medium.

Helpful?

more options

If you have followed instructions to set up various settings as mentioned above, but discover they have been reset after closing Thunderbird. Do you use a product designed to cleanup files eg: CCleaner and some Anti-Virus products also provide options to clean up files?

It is important that if you have programs performing cleanup operations that you exclude Thunderbird profile folder from the cleanup. It is well known that these 'cleanup' products remove files such as 'session', 'cache', 'cookies', 'passwords' etc. They can have annoying effects on Thunderbird as settings get deleted, sometimes it is a mere iritation other times it can be more serious.

Helpful?

more options

Dear Toad-Hall.

I am grateful for your detailed explanation! I have followed every suggestion you have come with and are excited to see how it works over the next days. Finally I somehow understand how TB function when it comes to font and size. To me it seems like an explanation like yours is needed to understand it, maybe in a later update your explanations could come up as popups. Oh, now I found out that one has to click on the image you made as illustration. I can see the difference then. Thanks !

Okulungisiwe ngu o.larsen1

Helpful?

more options

I was sure that everything would work now, after having followed your advice. When I tested, at first I was disappointed to see that text in "medium mode" was still very small. And it seemed as if it didnt matter if i changed the size of the font, as the text remained too small. Then I found out that the size is not measured in pt (points) which is the usual measure, but that it must be pixels! This means that to get the size that I like, which is 12 pt, I have to set it to 16, which would be huge in most other mail programs/text editors. I guess this has been the cause of the problem, as I then had to set it to "large" to be able to see what I was writing (Those who received my mails must have thought that it was written by someone who was blind :-) So I hope it will be ok now, also when I reply to mails, I have to answer some mails before I know.

Helpful?

more options

Well, something is still a bit strange... I have added an image. If you click on it, you can see that the text is not the same. The first (to the left) is the size when I write. The 2nd is how it looks in my "sent" folder. And the 3rd is how it looks in my inbox (I sent it to my self). So something must still be configured wrong......

Helpful?

more options

Please post a couple of images which show the current settings.

  • Menu app icon > Options
  • select 'General'
  • scroll to 'Language & appearance' section
  • click on 'Advanced' button to open the 'Fonts & encodings' window.

Post image showing the 'Fonts & encodings' window.


  • Menu app icon > Options
  • select 'Composition'
  • Under 'HTML Style' section

Please post image showing everything in the HTML Style section

Helpful?

more options

Thanks for offering your help again!

Helpful?

more options

Isisombululo Esikhethiwe

I set up my system like yours to test. I managed to reproduce some alteration in size as yourself and also a font alteration.

This anomaly occured because I needed to set up the 'Fonts for' 'Other Writing systems' see attached image. There was a disparity in the settings. The 'Latin' said size was 16, but the 'Other Writing Systems' was set up with a different font and size. So if doing anything for 'Latin', make the changes and click on OK Then go back and repeat for other 'Fonts for': settings After doing the 'Other Writing Systems' setting click on OK which does close the window. then click on 'Advanced' to open again to check for any other 'Fonts for' setting. I'm not sure if any other 'Fonts for:' options would effect you.

I would also advise you change the minimum font to 14 or 16 as well, unless you want Thunderbird to allow senders to display a small font or indeed you yourself may want to use something smaller. But size 10 pixel is quite small if you are accustomed to 16.

Okulungisiwe ngu Toad-Hall

Helpful?

more options

Thanks again,

It made it better. You were right in "other systems" font size was set to 20 (must be because the OK button only can save one change made at a time, like you said somewhere in the tread). So now I have set everything to 16 in both "Latin" and "Other systems". But still the font is bigger in the "sent" folder and the inbox (when I send to myself) than what it was when I wrote the mail. If I write something and highlight it and choose format/size/large, it is exact same size as in the sent folder and inbox. If this is just how Thunderbird is, then I can live with that, but it would leave me with the thought that TB is very complicated for no reason. In my opinion it should be a simple thing to change font size in a mail program. Thank you for your patience.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.