Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

New folders are not being displayed until thunderbird restart - no way to refresh them

  • 12 uphendule
  • 1 inale nkinga
  • 36 views
  • Igcine ukuphendulwa ngu dave_c_v

more options

Hi - when I create a new folder they are not imediatly displayed in the folder list. There are some older posts from 2014/15 about this but non of the sugestions work. The only option is a restart of thunderbird which is so problematic I would rather move to a new email client if this is not fixed. this is happening in both my hotmail account and my yahoo account so pop/smtp and outlook exchange protocols. Thanks Dave...

Ama-screenshot ananyekiwe

All Replies (12)

more options

I can't reproduce this on a Hotmail IMAP account in 78.6.1/W10. Subfolders of the account or a subfolder appear immediately after creation in TB. Are you creating subfolders in webmail and then expecting them to appear in TB?

Helpful?

more options

Hi - Using yahoo mainly and I am creating the the folders in Thunderbird. I get the problem with hot mail as well. Also I have just move to a new laptop and installed a fresh copy of Thunderbird - I moved the profile folders across. I got this problem on the old and on the new laptop.

Helpful?

more options

See if the same thing happens in a new profile: Help/Troubleshooting, about:profiles, add an account and add a subfolder.

Helpful?

more options

Hi - After copying my profile to save it. I uninstalled thunderbird, deleted appdata\local\thunderbird and appdata\roaming\thunderbird. Re-installed thunderbird 78.6.1, logged in and and opened my yahoo mail. Adding a folder has exactly the same problem? See image I did not copy in or use my saved profile info.

Helpful?

more options

I don't have a Yahoo account to test, but I tried it with an AOL account, which is based on Yahoo Mail. Right-click the account in the Folder Pane, New Folder..., name the folder, OK, it appears immediately in the Folder Pane. Same with a subfolder of a subfolder. There's no need to open the Subscribe window.

Helpful?

more options

Hi - I have the subscribe window open to show I have right clicked and added the folder - but it does NOT show up immediately. I have to do a restart of Thunderbird to get it to show up. There is no way of refreshing. Closing and opening the folder view does not work. Only appears after the server is contacted on a restart.

Helpful?

more options

I do have a yahoo.com account. I right clicked the account name in the folder pane, selected new folder and it was added immediately. When I selected it the server was contacted and it checked for mail in the folder.

Perhaps try safe mode (restart with addons disabled from the help menu and continue in safe mode when prompted). Still have issues with the folder being created in safe mode?

Helpful?

more options

Hi - I get the same result in safe mode with network. When TBird came up and contacted yahoo the invisible folder from before came up. When I tried to create a new folder as before. Subscibe panel can see it but the folder view cannot. So with this fresh install of thunderbird I created a test yahoo email account. Added this to thunderbird. I get the same problem. So with a new yahoo account and new thunderbird there is this problem that new folders do not show up in the folder list when created but are there when viewed in subscribe and appear in the folder list after a thunderbird restart.

I have also tried a Hotmail account and the folders work as expected.

Helpful?

more options

Does the following work in this specific order or not ?

  • Right-click on your mail account name folder in Folder Pane and select 'Subscribe'
  • click on 'Refresh'
  • Available IMAP folders on the server will be listed.
  • Select the ones that you want to add to your mail client
  • click the 'Subscribe' button.
  • Press the 'OK' button

Does the following work in this specific order or not ?

  • Right-click on your mail account name folder in Folder Pane and select 'Subscribe'
  • Select the new folder
  • click on 'Unsubscribe'
  • Select new folder again
  • click the 'Subscribe' button.
  • Press the 'OK' button

Does clicking on 'Get Messages' for yahoo force display of new folders?

Does collapsing the folder that should contain the new subfolder and then expanding again force display of new folder?


Can you tell us what you have in these settings to give us an understanding of your account settings.

  • Right click on imap mail account name in Folder Pane and select 'Settings'
  • Select : 'Server settings'
  • click on 'Advanced' button

Are these checkboxes selected?

  • 'Show only subscribed folders'
  • 'server supports folders that contain subfolders and mesages'
  • click on Ok
  • Select 'Synchronisation & Storage'

Message synchronising:

  • Is this checkbox selected 'Keep messages in all folders for this account....' ?

Helpful?

more options

Hi T Hall - just about done everything regarding refresh in the subscribe folder to no effect. Checked the sync setting and all is how it should be. Attached file. Howeve I have found a discrepancy at last. So the image of the subscibe window shows I have added test2 under the inbox, the image of "Items for offline use" does not show this folder so can't select it. Three images attached.

Helpful?

more options

I notice that you added 'test2' to Inbox. I presume it does not show up in Folder Pane. I notice it is in the Subscribe list, but not selected/subscribed to be seen - the checkbox is not selected, which explains why it is not in the Folder Pane nor in the 'Items for Offline use'.

However, if you create a new folder in Thunderbird you would expect it to be auto selected to be subscribed and auto displayed in Folder Pane.

I'm surprised that the following did not work: selecting 'test2' in Subscribe list and click on 'Subscribe', click on OK Then Collapse and expand the folder list for the whole account. Maybe it did not check due to a setting.

  • Menu app icon > Options
  • select 'General'
  • Scroll to the very bottom OR type 'config' into search
  • Click on 'Config Editor' button
  • Accept the risk
  • In search type: default.check
  • Look for this line: mail.server.default.check_all_folders_for_new

If set to 'false':

  • double click on that line to toggle the value to 'True'
  • close 'about:config' window - top right x

If already set to True, exit 'about:config' and let's try a different route. This should force a view of the folder.

  • Right click on imap mail account name in Folder Pane and select 'Settings'
  • Select : 'Server settings'
  • click on 'Advanced' button
  • uncheck: 'Show only subscribed folders'
  • click on Ok

Helpful?

more options

Hi - Ok put those setting in so the mail.server.default.check_all_folders_for_new was false now set to new. 'Show only subscribed folders' now unchecked Restarted TB Same result - created test26thJan under inbox - see images.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.