Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox won't play any videos on a fresh install

  • 3 uphendule
  • 1 inale nkinga
  • 26 views
  • Igcine ukuphendulwa ngu FredMcD

more options

I just formatted and installed Windows 10 (Pro N, 64-bit, 1909 update) and then installed firefox.

To my surprise, no videos can be played on any website (except youtube).

The video either doesn't load or shows the "Error loading player: No playable sources found" error.

I had no extensions installed, tried refreshing, tried disabling hardware acceleration; nothing solved it.

All content plays fine on chrome.

Isisombululo esikhethiwe

If you have Windows 10 N or KN then you may not have the Media Feature Pack installed. https://support.mozilla.org/en-US/kb/fix-video-audio-problems-firefox-windows

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (3)

more options

Isisombululo Esikhethiwe

If you have Windows 10 N or KN then you may not have the Media Feature Pack installed. https://support.mozilla.org/en-US/kb/fix-video-audio-problems-firefox-windows

Helpful?

more options

Thanks Fred, installing the media feature pack solved the problem

Helpful?

more options

Glad to help. Safe Surfing.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.