Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 84.0.2 not playing embedded Youtube videos.

  • 11 uphendule
  • 1 inale nkinga
  • 11 views
  • Igcine ukuphendulwa ngu FredMcD

more options

Getting errors messages like;

An error occurred. Please try again later. (Playback ID: esTXxYqBr25ETVYS)

Tried resetting FF, clearing cache and cookies etc. to no avail.

This started about a week ago.

Youtube webpage is working properly, just embedded videos are fubar.

Grrrrrrrrrrrrrr

Isisombululo esikhethiwe

Great. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (11)

more options

Helpful?

more options

No help !

Helpful?

more options

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Helpful?

more options

Safe mode - no fix, problem still there

Cleared cookies and cache - no fix, problem still there

(

No problems with Chrome but I don't like that browser  :P

Helpful?

more options

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Helpful?

more options

Started PC in safe mode.

Problem persists !

Firefox won't play embedded videos, playback direct from Youtube page OK

Helpful?

more options

Helpful?

more options

New profile works !

Thanks  :)

Short-lived joy - broke again

(

Okulungisiwe ngu audio_downunder

Helpful?

more options

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution.

Thank you for contacting Mozilla Support.

Helpful?

more options

Latest FF85 update appears to have fixed the problem !

Helpful?

more options

Isisombululo Esikhethiwe

Great. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems.

Okulungisiwe ngu FredMcD

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.