Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't log in to GMail SMTP Server from TB

  • 12 uphendule
  • 1 inale nkinga
  • 100 views
  • Igcine ukuphendulwa ngu Greg_B

more options

I have recently changed from using Microsoft Online to GMail service (not by choice). I now have a problem in that I cannot send emails from TB because TB still wants to sign in to the Microsoft SMTP server, not the GMail SMTP server. I have tried various strategies, including delete / recreate account, but TB insists that I need to log in to the MS server. So atm I am receiving / viewing emails in TB (because I prefer TB), but sending / replying via GMail. Please help.

OS = openSUSE Leap 15.2 TB = 78.6.0

Isisombululo esikhethiwe

I would right-click the two preferences that still refer to the MS OAuth server, Reset, restart TB, and then try sending. It seems that removing the MS account failed to clean out all settings.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (12)

more options

Select the gmail account in the left pane of Tools/Account Settings, then look at the Outgoing Server (SMTP) in the right pane. It appears the gmail account is set to send through the MS smtp instead of the gmail smtp. If the gmail smtp doesn't appear in the drop-down menu, add it to Outgoing Server (SMTP) at the bottom left of Account Settings: smtp.gmail.com on 587, STARTTLS (or 465, SSL/TLS), OAuth2 authentication. Check that the authentication for the incoming server is also OAuth2 and that cookies are allowed in Edit/Preferences/Privacy & Security.

Helpful?

more options

The outgoing server is set to the gmail smtp server.

Port = 465 Authentication method = OAuth2 Connection security = SSL/TLS

Accept cookies = checked, accept third party cookies = Always.

It still insists on logging in to the MS smtp server.

Helpful?

more options

Is the MS SMTP server still listed in Thunderbird alongside the Gmail SMTP server?

Helpful?

more options

No. The GMail server is the only available option.

https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2021-01-17-15-56-09-180d10.png

Here is a screenshot of what is going on when I "send". Everything says "use the GMail server", except for the actual login.

https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2021-01-17-15-57-31-5a0214.png

Helpful?

more options

This is a bit circular, but it might shed light.

Go to the help troubleshooting information in the help menu. In the mail and news accounts section of the troubleshooting information note the account ID. also check the SMTP server listed against the account. As they are entered for each identity you might have more than one . open the Config Editor search in the config editor for smtpServer was only one result returned? if so go to step 5 below and search n the value part of the preference.

  1. search for the account ID you noted earlier.
  2. In the preference listed mail.account.[accountID].identities you will see a value for the identity numbers of the account. Normally there is only one but it is a comma separated list.
  3. Now search for the values in the mail.account.[accountID].identities individual values (looks like id21)
  4. in the returned results will be mail.identity.[identity number.smtpServer and an SMTP reference that might look like (smtp15)
  5. (You got it) search for the SMTP reference.

In the returned results are there any references to Microsoft?

Helpful?

more options

Why are you trying to connect to the gmail smtp? Your account is provided by MS. Try setting the smtp server to smtp.office365.com on 587, STARTTLS, OAuth2. If you need to send through the gmail smtp, add the melbpc account in Gmail settings, Accounts & Import, Send mail as.

Helpful?

more options

sfhowes, Maybe I need to explain further. I am a member of Melbourne PC User Group - melbpc.org.au - who handles my email. They used to outsource the service to Microsoft through MS Office. They recently changed to outsource through Google GMail. That is why I need to attache to the GMail SMTP.

Helpful?

more options

Matt, Almost there! Thanks.

https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2021-01-17-20-31-38-db1dd5.png

What to do now? Can I delete the Microsoft entries? Or edit them the some GMaily thing?

Helpful?

more options

Are you able to receive mail for this account, and is it through outlook.office365.com or imap.gmail.com?

Helpful?

more options

Incoming mail works fine, server is imap.gmail.com It's only a problem sending from TB (can send ok when logged into GMail.com account)

Helpful?

more options

Isisombululo Esikhethiwe

I would right-click the two preferences that still refer to the MS OAuth server, Reset, restart TB, and then try sending. It seems that removing the MS account failed to clean out all settings.

Helpful?

more options

Thanks.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.