Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't access site in firefox that I can in safari

  • 6 uphendule
  • 1 inale nkinga
  • 14 views
  • Igcine ukuphendulwa ngu jscher2000

more options

There is a site that I've been accessing for months from firefox. Today, all my attempts to access it result in "Forbidden: You don't have permission to access this resource." If I bring up a safari browser, the exact same URL loads fine. I didn't change any firefox configuration settings. Any ideas?

Isisombululo esikhethiwe

Oh, maybe it's a server that has both an internal and external address ("split-horizon"), so DoH finds the external address and therefore Firefox doesn't "fall back" to alternate DNS to find the internal address.

You could try creating an exception for that host name:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste TRR and pause while the list is filtered

(3) Double-click the network.trr.excluded-domains preference to display an editing field.

  • If this field is blank, enter the domain name -- example.com -- and press Enter or click the blue check mark button to save the change.
  • If this field already has text in it, add a comma at the end, and then enter the domain name -- example.org,example.com -- and press Enter or click the blue check mark button to save the change.

(I don't have a way to test that with split-horizon domains.)

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (6)

more options

Is that followed by a new paragraph with a Reference number?

If so, that message would be characteristic of a "web application firewall" or similar security service used by the site that is blocking suspicious connections.

If you are using a VPN or have modified Firefox to limit certain information normally sent to websites, that could explain the issue. However, it is a bit of a guess because these services are purposely vague about their criteria for blocking.

Otherwise, you could try "the usual":

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache (Just web cache, not all your cookies and site data)

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that.

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart. A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

If Firefox is not running: Hold down the option/alt key when starting Firefox. (On Windows, hold down the Shift key instead of the option/alt key.) A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Helpful?

more options

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

Helpful?

more options

Thank you for your responses. Unfortunately, I'm still getting the same result after trying everything that you suggested.

There is no additional data after the error message. The only thing on the entire page is "Forbidden. You don't have permission to access this resource."

I am connected to a VPN, since this site is available only on VPN. As I mentioned, the site has worked for months on firefox, but today it just stopped. I didn't change any firefox or VPN settings on my end.

Helpful?

more options

Just to round this out, I've tried everything I could find to do, including complete uninstall and reinstall of firefox; deleting profiles; and deleting all browsing history, cookies, etc. Same result. I'm really disappointed because this is forcing me to use a different browser, which I don't like nearly as much as Firefox.

If anyone reads this down the road and has any suggestions, please let me know.

Helpful?

more options

OK, I finally resolved it. Turns out that DNS over HTTPS was the culprit. When I disabled that, I was able to access the site again. I followed the steps here:

https://support.mozilla.org/en-US/kb/firefox-dns-over-https

I wish I could keep this enabled, but that's a question for my company's IT team.

Helpful?

more options

Isisombululo Esikhethiwe

Oh, maybe it's a server that has both an internal and external address ("split-horizon"), so DoH finds the external address and therefore Firefox doesn't "fall back" to alternate DNS to find the internal address.

You could try creating an exception for that host name:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste TRR and pause while the list is filtered

(3) Double-click the network.trr.excluded-domains preference to display an editing field.

  • If this field is blank, enter the domain name -- example.com -- and press Enter or click the blue check mark button to save the change.
  • If this field already has text in it, add a comma at the end, and then enter the domain name -- example.org,example.com -- and press Enter or click the blue check mark button to save the change.

(I don't have a way to test that with split-horizon domains.)

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.