Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot install on Ubuntu 20.04

  • 4 uphendule
  • 3 zinale nkinga
  • 16 views
  • Igcine ukuphendulwa ngu Thom Andrews

more options

Hi

I just got Mozilla VPN but am unable to install it on Ubuntu 20.04. I added the PPA here, but when I go to install it, it complains with the following error:

``` hugh@hugh:~$ sudo apt install mozillavpn Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies.

mozillavpn : Depends: qt515base (>= 5.15.2-1basyskom4) but it is not installable
             Depends: qt515charts-no-lgpl (>= 5.15.2-1basyskom1) but it is not installable
             Depends: qt515declarative (>= 5.15.2-1basyskom1) but it is not installable
             Depends: qt515graphicaleffects (>= 5.15.2-1basyskom1) but it is not installable
             Depends: qt515imageformats (>= 5.15.2-1basyskom) but it is not installable
             Depends: qt515networkauth-no-lgpl (>= 5.15.2-1basyskom1) but it is not installable
             Depends: qt515quickcontrols2 (>= 5.15.2-1basyskom1) but it is not installable
             Depends: qt515svg (>= 5.15.2-1basyskom1) but it is not installable

```

I have tried to install Qt multiple ways and all have succeeded, but the mozillavpn install still has the same error:

  • sudo apt install qt5-default
  • sudo apt install qtbase5-dev
  • Installing QT via the GUI installer from their website

Thanks for your help

All Replies (4)

more options

I am also trying to install on Linux Mint 20 Cinnamon (which is based on Ubuntu 20) and I am getting the exact same message. I tried via the command line and also via Synaptic The following packages have unmet dependencies:

mozillavpn : Depends: qt515base (>= 5.15.2-1basyskom4) but it is not installable
             Depends: qt515charts-no-lgpl (>= 5.15.2-1basyskom1) but it is not installable
             Depends: qt515declarative (>= 5.15.2-1basyskom1) but it is not installable
             Depends: qt515graphicaleffects (>= 5.15.2-1basyskom1) but it is not installable
             Depends: qt515imageformats (>= 5.15.2-1basyskom) but it is not installable
             Depends: qt515networkauth-no-lgpl (>= 5.15.2-1basyskom1) but it is not installable
             Depends: qt515quickcontrols2 (>= 5.15.2-1basyskom1) but it is not installable
             Depends: qt515svg (>= 5.15.2-1basyskom1) but it is not installable

E: Unable to correct problems, you have held broken packages.

Helpful?

more options

Solved

Solution is to add this PPA and then try and install mozillavpn again

Helpful?

more options

Looks like that the current available version of QT5 via the default repositories is 5.12, however, mozillavpn requires at least 5.15; my installed version is 5.12.8+dfsg-0ubuntu1, however mozillavpn requires 5.15.2-1basyskom4 or later. There should be further installation instructions to denote the other required repositories if others are required or Mozilla should be ensuring that they check compatibility with the OS' default repositories before releasing.

Looks like the required repository is https://launchpad.net/~beineri/+archive/ubuntu/opt-qt-5.15.2-focal/+build/20381234, however, I'm not sure I want to really add a repository I don't know unless Mozilla were to expressly say I have to add it.

Okulungisiwe ngu Thom Andrews

Helpful?

more options

Really Mozilla should be checking the compatibility with the default repositories (the current qt5 version in the Ubuntu respository is 5.12.8+dfsg-0ubuntu1) or documenting related required repositories.

I would link to the required respository, but if I put a link in my post, it immediately gets deleted... Search "5.15.2-1basyskom4" in your favourite search engine and you'll find it's launchpad URL. Though should we really be need to add an extra repository?

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.