Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Autofil instead of

  • 1 baphendule
  • 1 inale nkinga
  • Igcine ukuphendulwa ngu jscher2000

more options

Hi, When I type in 'Go' or 'Goo' or even just 'G' it autofils '',

Yes, I want to go to Google but I would much prefer to go to Maybe that's just psychological.

I don't remember this happening before.. I have tried Shift+Delete but that doesn't work.

It is VERY annoying, I would rather use a different Browser maybe if Firefox can't allow such a basic choice?


All Replies (1)

more options

Hi, this is a hard problem to solve because even if you completely flush all knowledge of from your Firefox for a few moments, it will quickly reappear due to the way Google provides its services. Firefox's in-address-bar autofill feature doesn't provide a way to prioritize between the two.

Are you trying to load the Google UK home page to run a search? As a workaround, you could consider submitting your search to Google UK from the address bar. I posted an extension for that:


Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.