Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Certificate Issue - Google & Amazon

  • 4 uphendule
  • 1 inale nkinga
  • 624 views
  • Igcine ukuphendulwa ngu FredMcD

more options

Hello all,

Since this morning I'm having a huge issue in FF: I can not connect connect to many websites such as google, facebook, amazon...

SEC_ERROR_UNKNOWN_ISSUER

It comes from a certificate issue emitted by DigiCert, It is the DigiCert Global Root G1A. Yet this certificate does not exist, in DigiCert database. And worse, on their dignostic tool, the websites use the DigiCert Global CA G2 I could not bypass the certificate acceptance because of HSTS protocol. I looked at the clock, no problem. I used chrome, it worked.

I found a way to work around this problem: I went to about:config and put the security.enterprise_roots.enabled on TRUE.

I could connect again to websites.

BUT, not I have an additional issue: I can not log-in in amazon. I can be on the website, but when I try to log-in, nothing happen. No error message. Nothing. Just an infinite search time (the dots in the tab are moving back and forth). It send a request to fls-eu.amazon.com and it never arrives.

I also tried on Chrome, perfect. So this is typically a FF problem. And I'm stuck...

Do you have any fix? (I really do not want to switch to Chrome...)

Isisombululo esikhethiwe

I actually found a fix here: I set my network preferences to "no proxy". All was solved.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (4)

more options

Hi, it can be related to an antivirus intercepting your web traffic in a broken way. Do you have an AV and did you try turning it off?

more options
  • MOZILLA_PKIX_ERROR_MITM_DETECTED
  • uses an invalid security certificate SSL_ERROR_BAD_CERT_DOMAIN
  • configured their website improperly

How to troubleshoot the error code "SEC_ERROR_UNKNOWN_ISSUER" on secure websites https://support.mozilla.org/en-US/kb/troubleshoot-SEC_ERROR_UNKNOWN_ISSUER

more options

Isisombululo Esikhethiwe

I actually found a fix here: I set my network preferences to "no proxy". All was solved.

more options

That was very good work. Well Done.