On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Many images do not show up

  • 2 uphendule
  • 1 inale nkinga
  • 31 views
  • Igcine ukuphendulwa ngu cor-el

more options

Please be patient am old, lol. Example, I have a Yahoo home page and click on something I want to read it opens and most is ok the video on the page is fine, it works but there is a still photo a little further down in the article that does not show. If I open the exact same article in Chrome or Edge it is fine everything is visible. I have noticed every once in a while where the image should be it looks like it is moving in a waving motion but still no image. I have gone to the page info looked under permissions and do not see anything for allow images but there is Autoplay that shows: Picture below And If I go to Media and start clicking on the image addresses until I find the one that should be there it does show it. I do work from home and I don’t want to quit using Firefox but I really need it to work. Any help would be greatly appreciated.

Please be patient am old, lol. Example, I have a Yahoo home page and click on something I want to read it opens and most is ok the video on the page is fine, it works but there is a still photo a little further down in the article that does not show. If I open the exact same article in Chrome or Edge it is fine everything is visible. I have noticed every once in a while where the image should be it looks like it is moving in a waving motion but still no image. I have gone to the page info looked under permissions and do not see anything for allow images but there is Autoplay that shows: Picture below And If I go to Media and start clicking on the image addresses until I find the one that should be there it does show it. I do work from home and I don’t want to quit using Firefox but I really need it to work. Any help would be greatly appreciated.
Ama-screenshot ananyekiwe

All Replies (2)

more options

A screenshot of the issue would be nice.

more options

Autoplay has nothing to do with images (this is about playing videos).

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check the Web Console for messages about blocked content.


Make sure you haven't enabled a High Contrast theme in the OS settings.

Make sure you allow pages to choose their own colors as this affects background images.

  • Options/Preferences -> General: Fonts & Colors -> Colors: "Override the colors specified by the page with my selections above"

Try "Never" if the default "Only with High Contrast themes" isn't working.