Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Email links opening new browser session

  • 7 uphendule
  • 1 inale nkinga
  • 101 views
  • Igcine ukuphendulwa ngu pa1

more options

Recently when clicking on a link in an email, a new Firefox browser opens rather than the clicked website being added to the already open browser. How do I set email links to be added to the already open browser as has been the case for a long time? Thank you

Recently when clicking on a link in an email, a new Firefox browser opens rather than the clicked website being added to the already open browser. How do I set email links to be added to the already open browser as has been the case for a long time? Thank you

Isisombululo esikhethiwe

You can check this pref> on the about:config page.

External Links:

  • browser.link.open_newwindow.override.external

If this pref has the default value -1 then browser.link.open_newwindow is used. The meaning of the value of browser.link.open_newwindow.override.external is the same as of browser.link.open_newwindow

  • 1:current tab; 2:new window; 3:new tab;
Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (7)

more options

Do you have this option set?

more options

Isisombululo Esikhethiwe

You can check this pref> on the about:config page.

External Links:

  • browser.link.open_newwindow.override.external

If this pref has the default value -1 then browser.link.open_newwindow is used. The meaning of the value of browser.link.open_newwindow.override.external is the same as of browser.link.open_newwindow

  • 1:current tab; 2:new window; 3:new tab;
more options

jonzn4SUSE - I ticked "Open links in tabs instead of new window" and that worked for a while but has reverted back to opening a new window despite that box still being ticked.

cor-el - I cannot find about:config. Would you please point me in the right direction?

Thank you

more options

You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".

more options

When I open a link in a mail the link opens in a complete new Firefox session, not just in a new window. I used about:config. Changed browser.link.open_newwindow.override.external instead of -1 in 3. But that doesn't work. The link opens still in a new session of Firefox. In the task bar I see a new Firefox session. Normally when I open a new window in Firefox I see 1 Firefox session in the task bar and I can choose between 2 windows. What can I do about it?

more options

By the way: "Open links in tabs instead of new window" is marked and it works fine within Firefox. Only external links have this problem.

more options

That is my problem too - "Only external links have this problem."

When opening an attachment such as a PDF or spreadsheet for example, it opens in a new Firefox session window AND disables Firefox as my default browser.

I want to have only one Firefox browser open at any time, not 2 and I want Firefox to always be my default browser. I have configured these in Options - “Currently Firefox is your default browser” and “Open links in tabs instead of new windows” but both of these instructions are overridden.