Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Hyperlinks Won't Open Browser

more options

Clicking on links within emails no longer opens the page in my browser. I followed the different steps in this article (https://support.mozilla.org/en-US/kb/hyperlinks-in-messages-not-working), specifically the following:

  • Confirmed that Chrome is set as the default browser
  • Checked that no application is specified for the HTTP content type
  • Checked for an incorrect preference (no network.protocol-handler preferences found)
  • Started Thunderbird in Safe Mode

None of these resolved the problem. I am running Windows 10 Home on a Dell Inspiron.

Any help would be greatly appreciated.

Thanks, G.C.

All Replies (3)

more options

Same here except Win 10 Pro. I have no answer other than to right click on the link and select Copy Link Location and paste that in a new window in your browser.


BTW, it is not helpful that clicking on "I have this problem, too" before fully composing one's message causes the upper right portion of the message window to be covered by the Thanks message. I could see no obvious way to get the message to go away because the button to do so was off screen. Considerably widening the browser window allowed me to see it.

Helpful?

more options

I have just noticed that I have the same issue with Signal, so it doesn't seem to be T'Bird. But links within Chrome certainly work OK.

Helpful?

more options

Found this https://answers.microsoft.com/en-us/windows/forum/apps_windows_10-outlook_mail-winpc/windows-10-mail-will-not-open-hyperlinks-embedded/24fd566f-dc27-46a0-a90e-a74aad3068a1#:~:text=Windows%2010%20mail%20will%20not%20open%20hyperlinks%20embedded%20in%20the%20email.,-When%20you%20click&text=Go%20to%20Settings%20%3E%20System%20%3E%20Default,in%20a%20mail%20message%20again.

and tried changing the default browser to Firefox and links now work. Changing back to Chrome breaks it again.

Aha! Found this https://support.google.com/chrome/thread/16859237?hl=en Where one of the responses was: Pete Franetovich 1/9/20

I did two things and it worked. 1) I changed my default browser from chrome to another browser, then back to chrome. 2) I closed all chrome windows. Then opened chrome up again.

This also worked for me. Whew!

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.