Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How Do I Stop Thunderbird From Using Chromium As The Default Browser?

  • 6 uphendule
  • 1 inale nkinga
  • 1631 views
  • Igcine ukuphendulwa ngu Parasnailer

more options

I use Firefox as my main browser. In the past when I clicked on links in Thunderbird's RSS reader it opened those links in Firefox.

Recently I also installed Chromium. I did not set Chromium as the default system browser. But now, whenever I click on a link in Thunderbird's feed reader it opens up Chromium*.

Does anyone know how to fix this?

I'm using Arch GNU/Linux.

  • - Yes I have got it the right way around! I could understand it if Thunderbird always opens Firefox despite settings. But that's not what's happening, Thunderbird is always opening Chromium.
I use Firefox as my main browser. In the past when I clicked on links in Thunderbird's RSS reader it opened those links in Firefox. Recently I also installed Chromium. I did not set Chromium as the default system browser. But now, whenever I click on a link in Thunderbird's feed reader it opens up Chromium*. Does anyone know how to fix this? I'm using Arch GNU/Linux. * - Yes I have got it the right way around! I could understand it if Thunderbird always opens Firefox despite settings. But that's not what's happening, Thunderbird is always opening Chromium.

Isisombululo esikhethiwe

Des Leavy said

I have the same issue. It is not attachments, it is any link that is clicked that will open in Chromium. Is the only solution to remove chromium?

this is nothing to do with actual attachments, so please check the settings and run though everything.

Exit Thunderbird. Make Firefox your default browser: https://support.mozilla.org/en-US/kb/make-firefox-your-default-browser

Start Thunderbird Now check to see if the http and https setting is pointing to the wrong browser. If using Windows OS then: Menu app icon > Options > General scroll down to 'Files & Attachments' section Do you see any mention of http and https in the 'Content Type' column ? Either delete the setting or choose specific browser. then restart Thunderbird.

Please report back on what you discovered.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (6)

more options

Firefox is no longer you default browser.

Wrong is basically the same as none. See https://support.mozilla.org/en-US/kb/hyperlinks-in-messages-not-working

more options

Matt said

Firefox is no longer you default browser. Wrong is basically the same as none. See https://support.mozilla.org/en-US/kb/hyperlinks-in-messages-not-working

Thank you.

Firefox is definitely still my default browser. I've checked in the Xfce4 settings menu. Also, it still opens hyperlinks from everywhere else on the system. If I click on a link in the file manager or in Emacs then it opens Firefox. It's only Thunderbird that opens Chromium.

The link you give is useful though. It may be that Chromium has hijacked the file type for http or https inside Thunderbird. But how do I reset that? The instructions in that link says to go to "Edit > Preferences and click on the Attachments panel". That place in preferences doesn't seem to exist anymore. The attachments section of composition says nothing about file types.

more options

re :The instructions in that link says to go to "Edit > Preferences and click on the Attachments panel". They were the instruction to locate for versions prior to 78. Version 78* Menu app icon (3 lines) > Preferences OR Edit → Preferences Select 'General' Scroll down to 'Files & Attachments' section

more options

I have the same issue. It is not attachments, it is any link that is clicked that will open in Chromium. Is the only solution to remove chromium?

more options

Isisombululo Esikhethiwe

Des Leavy said

I have the same issue. It is not attachments, it is any link that is clicked that will open in Chromium. Is the only solution to remove chromium?

this is nothing to do with actual attachments, so please check the settings and run though everything.

Exit Thunderbird. Make Firefox your default browser: https://support.mozilla.org/en-US/kb/make-firefox-your-default-browser

Start Thunderbird Now check to see if the http and https setting is pointing to the wrong browser. If using Windows OS then: Menu app icon > Options > General scroll down to 'Files & Attachments' section Do you see any mention of http and https in the 'Content Type' column ? Either delete the setting or choose specific browser. then restart Thunderbird.

Please report back on what you discovered.

more options

Toad-Hall said

Des Leavy said

I have the same issue. It is not attachments, it is any link that is clicked that will open in Chromium. Is the only solution to remove chromium?

this is nothing to do with actual attachments, so please check the settings and run though everything.

Exit Thunderbird. Make Firefox your default browser: https://support.mozilla.org/en-US/kb/make-firefox-your-default-browser

Start Thunderbird Now check to see if the http and https setting is pointing to the wrong browser. If using Windows OS then: Menu app icon > Options > General scroll down to 'Files & Attachments' section Do you see any mention of http and https in the 'Content Type' column ? Either delete the setting or choose specific browser. then restart Thunderbird.

Please report back on what you discovered.

That worked for me Toad-Hall, thank you very much.

I don't think that button was in Firefox settings back when I first asked this question.