Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Anyway to disable "A script from the extension" "is running on this page"

  • 13 uphendule
  • 1 inale nkinga
  • 44 views
  • Igcine ukuphendulwa ngu davebesag

more options

I am getting sick of the message "A script from the extension...is running on this page" It relates to Adblock Plus which is the extension. I watch a YouTube video and then this message comes up on another YouTube tab I have open and Firefox switches to that tab and ruins my watching the video I was watching.

Is there anyway of disabling the message from ever coming up? I increased the values in dom.max_script_run_time and dom.max_script_run_time_without_important_user_input which was a possible solution I read but that does nothing.

All Replies (13)

more options

Is it the yellow bar saying a script is slowing down the tab? If not, what does it look like, I can't recall ever seeing one that mentioned an extension.

Helpful?

more options

Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

Helpful?

more options

It's happened again. I was going to give a screenshot anyway when it did.

Helpful?

more options

Start to load the web page. But STOP the page loading. After the page is loaded, click the AdBlock icon. Now select Disable on <website>. After, reload the page.

Helpful?

more options

Why should I have to disable AdBlock on YouTube because of Firefox? I want to disable the message which is completely unnecessary.

Helpful?

more options

I take it there's no way of disabling this message which came up yet again after I opened a new YouTube tab for all of one minute? It's getting ludicrous.

Helpful?

more options

Your screenshot mentions the uBlock Origin extension. There is a community support site for uBlock Origin on Reddit where you can ask about that dialog and get suggestions:

https://www.reddit.com/r/uBlockOrigin/

Helpful?

more options

Again the problem isn't uBlock Origin or Adblock Plus. It is Firefox not allowing me to disable this message which actually points me to an issue which isn't a problem for me. What it does is on occasions when I'm watching a YouTube video in one tab switch to another tab and show this unnecessary message which it looks like can't be disabled. I'm sorry but Firefox has become increasingly poor over the last few years. I've been a user of Firefox since it started and of Netscape before that but it's becoming worse and worse.

Helpful?

more options

What the screenshot shows is the uBlock scrip is taking too long to run and the browser thinks it is stuck. See if this helps.

”Webpage is slowing down your browser” This is the new way the browser tells you there is a problem with the script program(s). https://support.mozilla.org/en-US/kb/warning-unresponsive-script?cache=no

https://support.mozilla.org/en-US/kb/task-manager-tabs-or-extensions-are-slowing-firefox

Okulungisiwe ngu FredMcD

Helpful?

more options

... ..

Okulungisiwe ngu davebesag

Helpful?

more options

As I wrote earlier changing dom.max_script_run_time does nothing to extend the time. Blocking scripts doesn't seem to stop it either although again the issue is Firefox demanding I know something I'm not that bothered about. It's making opening multiple an issue which is ridiculous.

Helpful?

more options

Is this with all websites/pages, some, a few?

Disable the AdBlock add-on.

Helpful?

more options

This whole exchange shows where Firefox is going wrong.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.