Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How do I have gmail open automatically when Firefox starts?

  • 7 uphendule
  • 1 inale nkinga
  • 249 views
  • Igcine ukuphendulwa ngu cor-el

more options

For as long as I can remember, my gmail used to automatically open the Inbox when I started Firefox. To do that, the Options>Home>Homepage and new windows>Custom URLs included the address of the gmail Inbox, i.e. https://mail.google.com/mail/u/0/#inbox.

However, since Firefox v82.0 installed, I cannot get gmail to open automatically on Firefox startup. Even time, I am forced to say I want to sign in and then enter user name and password (obviously I have those saved so i just have to accept their entry but that's not the point).

This is already annoying. However, as I live in a Spanish-speaking country, gmail automatically defaults to Spanish and I have to reset it, each time, to English. If the inbox opened as it used to do, it would presumably not default to Spanish ("helpful" Google service) as it never used to to that.

Firefox has my gmail username and password saved so what am I doing wrong? Why has this changed from earlier Firefox versions and I how do I get around whatever is forcing this?

For as long as I can remember, my gmail used to automatically open the Inbox when I started Firefox. To do that, the '''Options>Home>Homepage and new windows>Custom URLs''' included the address of the gmail Inbox, i.e. '''https://mail.google.com/mail/u/0/#inbox'''. However, since Firefox v82.0 installed, I cannot get gmail to open automatically on Firefox startup. Even time, I am forced to say I want to sign in and then enter user name and password (obviously I have those saved so i just have to accept their entry but that's not the point). This is already annoying. However, as I live in a Spanish-speaking country, gmail automatically defaults to Spanish and I have to reset it, each time, to English. If the inbox opened as it used to do, it would presumably not default to Spanish ("helpful" Google service) as it never used to to that. Firefox has my gmail username and password saved so what am I doing wrong? Why has this changed from earlier Firefox versions and I how do I get around whatever is forcing this?

Isisombululo esikhethiwe

OK. So in this sago over something stupid, I found the problem had returned. So I went back into options. All I tried is changing the setting to delete cookies at the end of the session. I do have cookies for gmail set as an exception. But when I stopped deleting any cookies, the problem went away. so it appears the cause of this problem is a bug. Firefox is ignoring the exception set to ignore Gmail when deleting cookies at the end of a session.

It now works but cookies cannot be deleted at the end of the session, which I suppose I'll live with.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (7)

more options

Are you saying you need to log in after closing the browser?


Your ‘logged-in’ status is stored in special cookies. If the cookie is removed, you are logged out.


You may be in Private Browsing mode or told Firefox not to remember.

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.


Firefox 82+ comes with a "Redirect Tracking Protection" feature to automatically purge tracking cookies for websites that haven't been visited recently, so if you clear the history then Firefox can clear cookies.

You can disable the feature to purge tracking cookies automatically via the about:config page. privacy.purge_trackers.enabled = false

You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".

https://support.mozilla.org/en-US/kb/about-config-editor-firefox

more options

Hi Fred.

Thanks for taking the time to reply.

Yes, I suppose what I am describing is a wish to "remain logged in" if I close and reopen Firefox, so the Gmail Inbox should appear in a tab when I start Firefox with no need to remember my password (that both Firefox and Bitwarden have recorded).

I did know of the cookies but may not have set up Firefox correctly. S, to make sure, I went in and tried to follow your instructions. Nothing was where you said (perhaps we have different Firefox versions) so I had to look around (I am on Firefox 82, specifically 82.0.2). I couldn't find anything wrong with my setup. I did go into cookies and delete them all so as to start afresh. Then, on separate tabs, I logged into my accounts for: Google, Gmail, Facebook and Youtube. I reset m home page to the "current tabs" setting. I also cleared the cookies exceptions list and added all the tab addresses to the exceptions as "Allowed" (i.e. always) so that cookies would be kept. And I set Firefox to remember my tabs (when i close and reopen Firefox). This works perfectly for Google, Facebook and Youtube. But it still fails for Gmail!!!

more options

Fixed it! (LATER EDIT: No! NOT FIXED!!! SEE BELOW - NEW COMMENT)

I'm half guessing. But what I think happened was that the two laptops I work on somehow failed to synchronise Firfex Options Settings. So whatever I did on one laptop could be out of sync with the other and who knows how the technology chose to cope with that.

What I did was set up both laptops at the same time with identical settings, all entered fresh no matter what the old setting was. I actually changed correct settings to incorrect ones so that ALL changes then made would be both new and correct on both machines. And that now seems to be working,

So, thanks Fred. I used your advice to check settings so it was helpful but I think it was the synchronisation that was the actual problem.

Stay safe.

Cheers.

Okulungisiwe ngu paulindr

more options

Were you using "Clear history when Firefox closes" to clear the browsing history as that can cause this issue ?

more options

Hi cor-el. Thanks for the question and comment. But no, I was not clearing the history. Also, since writing that I have solved the problem, I logged off of both laptops, left them overnight and found the problem had re-occurred!!! But I have now solved it - below!

more options

Isisombululo Esikhethiwe

OK. So in this sago over something stupid, I found the problem had returned. So I went back into options. All I tried is changing the setting to delete cookies at the end of the session. I do have cookies for gmail set as an exception. But when I stopped deleting any cookies, the problem went away. so it appears the cause of this problem is a bug. Firefox is ignoring the exception set to ignore Gmail when deleting cookies at the end of a session.

It now works but cookies cannot be deleted at the end of the session, which I suppose I'll live with.

more options

If you clear Cookies ans Site Preferences via "Clear history when Firefox closes" then all cookies are cleared. You can use "Delete cookies and site data when Firefox is closed" to clear cookies and keep cookies with an allow exception.