Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Printer settings

  • 13 uphendule
  • 1 inale nkinga
  • 50 views
  • Igcine ukuphendulwa ngu s.mburu

more options

After the new update to version 82.2 printer paper size restored to letter from postscript. Now i have to keep changing the paper size whenever I want to print. How can i make postscript as default when printing to PDFcreator printer

All Replies (13)

more options

This is a known bug that was in Firefox 82.0, but 82.0.1 should have prevented this happening if, and ONLY if, it hadn't already happened in 82.0. I'm guessing that you already printed using 82.0 before the update to 82.0.1/82.0.2, but maybe hadn't notice that?

If you open the page `about:config` and type in "print_paper", you should see a bunch of printer settings for your printer saved there. Try deleting all those settings for the affected printer(s) and see if that fixes things for you.

more options

Also, I think this should only have happened if you set the "print_paper_width" and "print_paper_height" values to -1. Do you know if you ever set them to that?

more options

Jonathan Watt thanks for the reply. I seen this with version 82.02 from most users. So i have downgraded to 81.0 and stopped automatic update. The only thing i changed on `about:config` is the "print.save_print_settings" to false. But the "print_paper_width" and "print_paper_height" are set to -1 as per attached picture, what should the values?

more options

You will see the problem in 82.0.2 unless you delete the "print_paper_*" settings as I mentioned above.

You can set "print_paper_width" and "print_paper_height" (back) to -1 rather than deleting them if you like. If they are set to -1, then Firefox should use the paper size defined in the operating system's printer settings. If you delete them, Firefox will do the same, but then update the "print_paper_width" and "print_paper_height" values with the dimensions that came from the operating system the next time you print. The difference is that if they're set to -1, Firefox will check the operating system settings every time you print, which may be slower. The only reason you might choose to use -1 is if you like to change the operating system settings frequently and want to have Firefox pick up those updated settings whenever you change them.

more options

I have deleted the "print_paper_*" for the printer still changing back to 'Letter' when i choose ‘Postscript Custom Page Size’ but if I use the preset paper forms like A4 it not reverting to letter.

more options

What dimensions is the 'Postscript Custom Page Size' paper size configured to?

more options

The dimensions set is Width: 11.50", Height: 8.50" and Paper Feed Direction is 'Short Edge First'

more options

Interesting, so half an inch longer than US Letter. Maybe we have a rounding error of some sort since it seems unlikely that that size specifically would otherwise coincidentally be the size that reverts to US Letter.

After the size has reset, what values do the "print_paper_*" prefs in `about:config` have? (Particularly "print_paper_id")?

more options

print_paper_id is 32767

more options

I think we probably need to dig deeper here. Can you create an account on https://bugzilla.mozilla.org/ and report this issue there for investigation by the developers?

more options

Jonathan, thanks for you time.

more options

No problem. Did you file a bugzilla bug? If so, I can't find it - can you provide the link here? If not, and if you're having trouble with filing a bugzilla bug we can continue the discussion here. It will just be a bit more cumbersome.

more options

I have just filled a bugzilla bug 1675694