Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How can I exclude urls ending with .lan from searching

  • 2 uphendule
  • 1 inale nkinga
  • 236 views
  • Igcine ukuphendulwa ngu joalbauer

more options

In my home network there are several servers whose URLs end with ".lan". For example http://nas.lan or http://router.lan. When I want to connect to these machines with Firefox, I usually type router.lan in the address bar. But then Firefox starts searching for router.lan on google. Afterwards I am asked if I had wanted to access http://router.lan instead and when I click "Yes" Firefox takes me where I actually wanted to go. However, this can get quite annoying over time, and I wonder if it is possible to tell Firefox to go directly to the URL I enter whenever it is a string ending with ".lan" and avoid to search for it? Don't get me wrong, I do not want to disable the search bar completely as I am very used to type in searches into the address bar directly.

In my home network there are several servers whose URLs end with ".lan". For example http://nas.lan or http://router.lan. When I want to connect to these machines with Firefox, I usually type router.lan in the address bar. But then Firefox starts searching for router.lan on google. Afterwards I am asked if I had wanted to access http://router.lan instead and when I click "Yes" Firefox takes me where I actually wanted to go. However, this can get quite annoying over time, and I wonder if it is possible to tell Firefox to go directly to the URL I enter whenever it is a string ending with ".lan" and avoid to search for it? Don't get me wrong, I do not want to disable the search bar completely as I am very used to type in searches into the address bar directly.

Isisombululo esikhethiwe

Hi, try this:

  • type about:config into the address bar and press enter.
  • Acknowledge the warning.
  • In the search box at the top enter `browser.fixup.domainsuffixwhitelist.lan` (without the quotes).
  • On the row that appears, make sure that Boolean is selected, then click the plus sign. This should create it with value "true".

Now you should be able to have the `lan` domain work as you want.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (2)

more options

Isisombululo Esikhethiwe

Hi, try this:

  • type about:config into the address bar and press enter.
  • Acknowledge the warning.
  • In the search box at the top enter `browser.fixup.domainsuffixwhitelist.lan` (without the quotes).
  • On the row that appears, make sure that Boolean is selected, then click the plus sign. This should create it with value "true".

Now you should be able to have the `lan` domain work as you want.

more options

You're the best. Thank you very much.