Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox 81.0 Stuck on Loading Stuff

  • 5 uphendule
  • 1 inale nkinga
  • 14 views
  • Igcine ukuphendulwa ngu ClumZyFinGerX

more options

Hi. Since the beginning of September, I hit into this strange incident. Eventually, I reinstall my computer in hope to get this fixed. Unfortunately, it didn't. It pops up again after 1 day.

This issue is quite strange, as I've said. When I get into YouTube, the user menu on the upper right corner will go on loading. The menu will never popped up at all. When I refresh the Firefox, this may get fixed in the first hour (it's much less, but I don't have any timing on this), and this will return. Other "interesting loading" may happen, say the "Kaspersky 2021" Add-on.

Other interesting thing is the user menu in YouTube won't complete, even it popped up. Half of it was shown. Normally, we may be able to swap accounts or logoff the account, but that entry wasn't in the menu.

Has everyone hit into this situation before, or is it just me? Any solution? Pls advise, thanks in advance.

Hi. Since the beginning of September, I hit into this strange incident. Eventually, I reinstall my computer in hope to get this fixed. Unfortunately, it didn't. It pops up again after 1 day. This issue is quite strange, as I've said. When I get into YouTube, the user menu on the upper right corner will go on loading. The menu will never popped up at all. When I refresh the Firefox, this may get fixed in the first hour (it's much less, but I don't have any timing on this), and this will return. Other "interesting loading" may happen, say the "Kaspersky 2021" Add-on. Other interesting thing is the user menu in YouTube won't complete, even it popped up. Half of it was shown. Normally, we may be able to swap accounts or logoff the account, but that entry wasn't in the menu. Has everyone hit into this situation before, or is it just me? Any solution? Pls advise, thanks in advance.
Ama-screenshot ananyekiwe

All Replies (6)

more options

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

more options

Thanks. I tried all the above, but it still didn't work. Don't know why?!

more options

Remove History For One Site {web link}

Open the History Manager <Control> (Mac=<Command>) <Shift> H. In the search bar, enter the name of the site. Right-click on one of the listings and select Forget About This Site. This should remove all information, including any site settings

more options

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

more options

Not sure if it's possible to post a video here: https://youtu.be/EghB2ay44ZY

This is what I've tried so far. The symptoms are still around. Anyway, thanks all for the help. Appreciate.

more options

More information that I missed deliver in the first place. Other browsers, installed along with this weird Firefox, doesn't seem to have these issues: Brave, Chrome and Edge etc.

Moreover, I'm using Firefox in office too. That Firefox doesn't have those issues as well.

This really makes me nuts. Why only this PC?!