Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

disabling private browsing using `policies.json` seems not work

  • 9 uphendule
  • 1 inale nkinga
  • 45 views
  • Igcine ukuphendulwa ngu lubegasimon

more options

I followed https://support.mozilla.org/en-US/questions/1229792#question-reply about, disabling private browsing using `policies.json`, but that seems not work.

PS: am using ubuntu 18.04

Ama-screenshot ananyekiwe

All Replies (9)

more options

The code that you have in your policies.json file appears to be correct, but the distribution folder needs to be located in the Firefox installation directory, not your bin folder. If you go to the about:support page in Firefox, the installation directory will be listed as the Update Directory on the Application Basics table.

For more information about using the policies.json file to enforce policies in Firefox, see the Customizing Firefox Using policies.json page.

Hope this helps.

Helpful?

more options

not yet helpful, am a bit confused. Basically I installed firefox via `Ubuntu Software` as a desktop application. I have done research on how to know the installation directory on ubuntu, I have found `which firefox` which points to `/usr/bin/firefox`

Helpful?

more options

Firefox from the Ubuntu repositories may behave differently and Ubuntu might be customizing Firefox in a way (e.g. via autoconfig.cfg) that overrides the policies.json file.

You can check the about:policies#active page to see whether policies are active (63+).

Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.


Helpful?

more options

Before installing a new firefox following https://www.mozilla.org/en-US/firefox/all/#product-desktop-release, which was installed successfully, checking about:policies#active, the policies were inactive, however, the new firefox, on policy was active ( DisableAppUpdate true ). So following Wesley's directive ( about:support ), my update directory is '/snap/firefox/418', which contained the distribution folder by default and policies.json files with content ``` {

 "policies": {
   "DisableAppUpdate": true
 }

} ```. So when I try to open the policies.json file using `nano policies.json`, to add policies, I get an error ( that the file system is read only ), see screen shot below.

Basically, file `policies.json` is unwritable. So how can I remove that restriction ?

Okulungisiwe ngu lubegasimon

Helpful?

more options

You need to run nano as root (sudo nano) to be able to edit this file as it is in a location owned by root.

Helpful?

more options

it also have to be said, that after downloading the new firefox, I opened it using `ubuntu archive software manager`, not a direct save.

Helpful?

more options

cor-el said

You need to run nano as root (sudo nano) to be able to edit this file as it is in a location owned by root.

sorry, I just forgot to include it in a post, but it's exactly what I did `sudo nano policies.json`.

See the error down in the terminal `file 'policies.json' is unwritable`

Okulungisiwe ngu lubegasimon

Helpful?

more options

Hmm. The screenshot shows it asks a password for simon and not the password for root. I don't if this is different on Ubuntu.

Helpful?

more options

cor-el said

Hmm. The screenshot shows it asks a password for simon and not the password for root. I don't if this is different on Ubuntu.

I did supply the password, I just wanted to show you that I had used ‘sudo nano’ before to open the policies file.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.