Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Thunderbird - twitter no app associated

  • 4 uphendule
  • 2 zinale nkinga
  • 145 views
  • Igcine ukuphendulwa ngu moomooleo

more options

I have recently done an "automated" update from Thunderbird v68.? to v68.12 and I'm seeing the following change.

Before this upgrade when I clicked on any link on an email from a Twitter user either the original message/video showed up and/or a link was opened in a new Firefox tab and I could watch the video. Now I get the following error and I can't resolve it. I can still open twitter in Firefox, but I am not allowed to copy or access the link in the Thunderbird Twitter message to run it in Firefox.

The error message displays a portion of the link being attempted and adds a text message "...This file does not have an app associated with it for performing this action. Please install an app or, if one is already installed, create an association in the Default Apps Settings page."

Other URL links in my email messages fire up automatically in Firefox when I click on them as before...

See the actual message in the attached image

Thanks

I have recently done an "automated" update from Thunderbird v68.? to v68.12 and I'm seeing the following change. Before this upgrade when I clicked on any link on an email from a Twitter user either the original message/video showed up and/or a link was opened in a new Firefox tab and I could watch the video. Now I get the following error and I can't resolve it. I can still open twitter in Firefox, but I am not allowed to copy or access the link in the Thunderbird Twitter message to run it in Firefox. The error message displays a portion of the link being attempted and adds a text message "...This file does not have an app associated with it for performing this action. Please install an app or, if one is already installed, create an association in the Default Apps Settings page." Other URL links in my email messages fire up automatically in Firefox when I click on them as before... See the actual message in the attached image Thanks
Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

Twitter has decided to change/in process of changing the API and therefore it has been removed from Thunderbird.

Menu app icon/File > New > Chat account Twitter is no longer in the list. It was removed a few versions ago.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (4)

more options

Isisombululo Esikhethiwe

Twitter has decided to change/in process of changing the API and therefore it has been removed from Thunderbird.

Menu app icon/File > New > Chat account Twitter is no longer in the list. It was removed a few versions ago.

more options

My mother encountered the same issue today. I had to remotely connect to her computer to fix the issue for her. Here's the fix:

1. In Thunderbird 78.4.3, navigate to Tools-->Options. Scroll all the way down to the "Config Editor" button. Click it.

2. Select "I Accept The Risk".

3. Search for "network.protocol-handler.warn-external.https" without the quotation marks.

The Twitter links that I'm sent are all https://

4. If network.protocol-handler.warn-external.https is set to false, right click on it, and select "Toggle", so that the value shows "true".

5. Exit Thunderbird. Run Thunderbird again.

6. Now click on the https://twitter link that you were emailed in Thunderbird.

7. A dialogue box will appear asking you to select the app. Presumably Firefox is already selected. The association doesn't work and needs to be fixed.

Select "Choose another application", and select the "Choose" button.

8. Locate firefox.exe on your computer. The location for me, since I'm running a 64 bit edition is C:\Program Files\Mozilla Firefox\firefox.exe

If you're running the 32 bit edition of Firefox, the file location might be found under C:\Program Files (x86)\Mozilla Firefox

Regardless, select the firefox executable file.

9. Check the box for "Remeber my choice for https links".

10. Click "Open Link"

11. Firefox should then launch your twitter link.

12. Go back into Thunderbird. Repeat steps 1 to 5, except this time change network.protocol-handler.warn-external.https to false in step 4.

13. That should fix the problem. If it doesn't, try going through the information listed at https://support.mozilla.org/en-US/kb/hyperlinks-in-messages-not-working starting with "Problems with received or saved mails" and work your way down.

Good luck!

more options

Toad-Hall said

Twitter has decided to change/in process of changing the API

The user's issue with Firefox not automatically loading Twitter links when clicking on them in Thunderbird has nothing to do with the API.

more options

ArrowFlynn, thank you very much for your expertise! Followed your response instructions and now things are pulling up in Firefox like before.