Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Problem with cache on Firefox Developer Edition

  • 10 uphendule
  • 2 zinale nkinga
  • 1095 views
  • Igcine ukuphendulwa ngu pmourer

more options

Hello,

I'm beginner in development. Today I'm working on some CSS files.

But when I reload, the content don't load the new features. I've try to clear cache, remove stockage on the console , and also try command + f5 (on iMac).

The only one solution I've founded is to clear cache , leave firefox , shutdown computer and restart.

Very contraignant. I've test on Chrome and it work well. So I don't know what I need to do to...

I'm using MAMP to lauch app on local

Isisombululo esikhethiwe

Hi Matheo, Firefox 79 has a new and more tenacious mechanism for caching CSS. Command+F5 or Shift-clicking the reload button in the toolbar should force a reload, but if that isn't working, you could try a different workaround: in the developer tools, if you click over to the Network tab, you can check the box for Disable Cache.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (10)

more options

Isisombululo Esikhethiwe

Hi Matheo, Firefox 79 has a new and more tenacious mechanism for caching CSS. Command+F5 or Shift-clicking the reload button in the toolbar should force a reload, but if that isn't working, you could try a different workaround: in the developer tools, if you click over to the Network tab, you can check the box for Disable Cache.

more options

Hello, Since one week (but i was in holidays the 2 previous weeks) Firefox cache turn me crazy. I disconnect from an account or reload a page (where content have been changed) and data are not updated. I have to empty cache each time to be sure data are the good one. To work in sites backoffice it's just a nightmare !

Also when i save a form sometimes it don't save values. It's crazy ... Big problem with cache system since one or 2 versions. Please correct this fast. Firefox become unusable.

Also : HOW TO CHANGE CACHE BEHAVIOUR ??? Now more option to set this ...

Regards.

Okulungisiwe ngu pascal12

more options

Hi pascal12, try turning off disk caching to see whether that helps:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste cache and pause while the list is filtered

(3) Double-click the browser.cache.disk.enable preference to switch the value from true to false

About this part --

pascal12 said

Also when i save a form sometimes it don't save values.

-- I'm not sure what you mean by saving the form. Do you mean when you submit the form, it isn't getting submitted successfully? That seems like a different problem, probably not related to excess caching.

more options

Hi pascal12, let's continue in your new thread here: https://support.mozilla.org/questions/1301655

more options

Hi Matheo, as another workaround, I created an extension you can use to temporarily prevent caching of CSS files from your own servers (or any servers, you create the host list and set the host permissions):

(I'm still trying to figure out a good user interface for managing addition and removal of host permissions. Hopefully Firefox will have a native one at some point.)

more options

I think it is ironic that the Firefox Developer edition caches. I'm having the same problem except it's caching on-the-page javascript. I have a script at the bottom of the page, since I'm working on it I want it where I can easily see the html and the javascript (later I'll put it in its own file). When I change any html, it changes in the browser, but when I change the javascript, it does not load the new javascript - very strange since it's on the same page. But when I go into Tools > Options > Privacy and Security > Cookies and Site Data > Clear Data and then select only Cached Web Content, it loads the new Javascript.

This is very annoying when I'm developing. If I forget, I might spend a lot of time trying to figure out what's wrong with my code, when there's nothing wrong with it, it's the stupid browser! It's the Developer edition for crying out loud! For this edition, make the default NO CACHE AT ALL!!!

Firefox Browser DEVELOPER Version 85.0b9 (64-bit)

Okulungisiwe ngu dscott.weaver

more options

I did find a work-around that seems to work. If view source (ctrl-U) and update the source page, no caching seems to be done there...

more options

dscott.weaver said

It's the Developer edition for crying out loud! For this edition, make the default NO CACHE AT ALL!!!

I realize it is frustrating, but it is unlikely that the default will be changed. To manually disable caching, you can make these preference changes:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste cache and pause while the list is filtered

(3) Disk caching: Double-click the browser.cache.disk.enable preference to switch the value from true to false

(4) Memory caching: Double-click the browser.cache.memory.enable preference to switch the value from true to false

More info on about:config: Configuration Editor for Firefox.

more options

Did you try to tick the checkbox in the developer tools to disable the cache while the tools are open ?

more options

having this issue in Mozilla Firefox 85.0.1

Disabled cache in the dev tools, spent 2 hours debugging a frontend problem. Found a solution to the problem: switch to chromium. forever. Not what i wanted, but i have a job to do.

Just remove the checkbox if it does nothing.

This was not CSS, this was the HTML document itself.

edit: also used hard refreshes to no avail

Okulungisiwe ngu pmourer