Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Spell checker not working

  • 17 uphendule
  • 4 zinale nkinga
  • 215 views
  • Igcine ukuphendulwa ngu cor-el

more options

Hi Guys and Girls,

For the love of all that is keeping me alive at the moment please help solving the issue of spell checker not working.

I have a new MacBook Pro and setup Firfox by installing it and siging in to sync.

The spell checker does not underline the words as I type here or in Google or WhatsApp Web.

Also when I right click no language opion appears.

I does work in Gmail for some weird reason.

After follwing a suggestion of installing an add-on dictionary and resarting Firefox, no change came about.

See attached for more...

Thanks in advance for your help.

Ama-screenshot ananyekiwe

All Replies (17)

more options

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar.

Type: layout.spellcheckDefault Its values are; 0 Spell Checker Off 1 Check Only Multi-Line Input Boxes. 2 Check Multi And Single Line Input Boxes.

Also, check the spellchecker.dictionary entry.

https://support.mozilla.org/en-US/kb/how-do-i-use-firefox-spell-checker

more options

Do you have a dictionary installed and selected?

You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu. At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • open the "Add Dictionaries" link to install a dictionary if you do not have one.

The spelling checker is enabled if [X] "Check Spelling" in the right-click context menu has a checkmark.

You can enable or disable spell checking globally:

  • Options/Preferences -> General: Language and Appearance: "Check your spelling as you type"

You can look here for dictionaries:

Note that for spell check you need a dictionary. A language pack provides string translations for the user interface.

You can check on the about:config page that layout.spellcheckDefault is set to 1 (multi-line) or 2 (single-line).

more options

Hello FredMcD, Hello co-rel,

Thank you kindly for your messages and willingness to assist.

After having done all the mentioned advises the issue remains.

See my attached screenshots.

Why does Firefox do somehting like this?

Hope you can help solve it.

more options

Attached now...

more options

The second and third screenshot show that you installed and enabled the en-GB language pack. Like I posted above, for spell check you need a dictionary. A language pack provides string translations for the user interface.

You can look here for dictionaries, so make sure to look in the Dictionaries column.

User installed dictionaries will appear under the Dictionaries heading in Options/Preferences.

more options

Several weeks ago, I wrote in that Firefox spell checker was often not working. I had worked through the process of checking that everything was set, and that there was an English dictionary installed. And the fact that it was often working showed that everything was properly set and ready to work. I did go ahead an install an other English dictionary, and it seemed to have solved the problem, and I market it solved. Now I can't find that reply, to say it was NOT fully solved.

Consistently, when I comment on an article in a web page, that uses Facebook's log-in to maintain its comments area, spell check does not work. All other sites or comment threads, such as Discus, seem to operate correctly.

more options

jdunfee12 said

. . . and I market it solved. Now I can't find that reply, to say it was NOT fully solved.

If you mean this thread, it is not solved. If you mean a different thread you created,

Go to the top of any support.mozilla.org web page and press your user icon to see your Mozilla profile. Including your questions and answers.

more options

Next time you find the spell checker not working, right-click in the field and check the spellcheck/dictionary settings.

more options

The web page can disable the Firefox spell checker via a spellcheck="false" attribute of an input field or textarea or editable element and possibly provide its own spelling checker.

You can check this via the right-click context menu in the Inspector.

more options

Spell checking used to work. I tried to follow the instructions above. Some notes:

  • I don't always get a "Languages" option when I right-click in an area that accepts text.
  • But I did get that option when I right-click on this text box herre.
  • And it does highlight "herre" as expected.
  • When I right-clicked here, I also saw a check mark on the "Check spelling" box.
  • about:config shows that I have the "en-US" dictionary installed.
  • But I reinstalled the US English dictionary again from the Languages option.

Here's the frustrating part: ... Spell checking is working here on this page, but ... Spell checking is NOT working on the posts I compose for Facebook.

Any other ideas?

more options

Did you check the outcome of my above reply about a website disabling the spell checker ?

more options

Thanks cor-el, but no joy.

On Facebook, I attempt to reply to a post, and I type in "herre", and the typo does not get highlighted. I note that it does get highlighted in this text box.

I right-click and bring up the Inspector. I even scroll to the top of the HTML for the page. When I search for "spell", it finds no matches. I use AdBlock Plus, but that shouldn't be an issue because spell checking is working here. I also use RevertSite on FB (reverts to the old user interface) -- that might be something. I'll contact them.

Any other ideas?

Thanks. looknsee

more options

You need to right-click in the text editor area and click Inspect Element to open the Inspector with this element selected. If there is a spellcheck attribute then this might explain this. With a rich text editor things might be different.

more options

Hi There, I jave now read many user forums about this issue, often they repeat the same standard advice on the procedure of adding dictionary/language, which has had no affect in fixing my issue. - The use of dictionary / language / lnaguage pack at different times is confusing. How are we to know the difference? In the pull down menu to 'add a language' the other two terms don't exist. This needs clarifying. - I have only an English (UK) 'language' installed into browser and the 'check as typing is always selected on. A screen shot of this section in preferences/general/language is attached. I haven't yet seen the solution on any of the forums so suggesting something you already have done is unlikely to resolve this. Please can you suggest a solution to fix my particular problem, it's driving me nuts! At the moment I'm typing in TextEditor then cut and pasting into Firefox ... a very unsatisfactory solution. I look forward to your help in fixing this. Mac OS 10.10.5 Mac Pro 2009 Firefox 78.7.0esr (64-bit) NB - The spell check while typing is not working as I write this. It's YouTube I rewuire spell check it most often. Thanks, Gavin

more options

What your above screenshot of Options/Preferences shows has nothing to do with spell checking. The first setting is about the language of the user interface and the second setting is for the preferred language of webpages.

For spell check you need to install a dictionary, especially if you use a locale that doesn't come with a dictionary like en-GB. See my above replies for details.

(fixed not working link: webpages -> web-pages)

Okulungisiwe ngu cor-el

more options

cor-el Thank You !!

The third link you shared gave me what I needed, I hadn't seen that link anywhere else, but I see now you have posted it before. I clicked on the 'Brit English Marco Pinto' link already highlighted because of my location, new webpage opened then one more click, it installed and it works!

No one else made it clear the dictionary needs to be downloaded from external 'Add-on' URL. https://addons.mozilla.org/firefox/language-tools/

I hope others find your straight forward advice. Cheers.

NB - Your second link is dead, it's and orphaned URL.

more options

You're welcome.

I fixed the broken link in my above reply.