Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox 79.0 History Settings

  • 17 uphendule
  • 1 inale nkinga
  • 59 views
  • Igcine ukuphendulwa ngu cor-el

more options

Hello,

I am running FF 79 with W10 OS.

I do a lot of browsing related to ancestry. After several hours of working thing get very sluggish. What I then do is bookmark the tabs I am working on and then shutdown and restart FF. I have the history set to Remember History it and then clear it when FF closes.

I want FF to remember my sign-in information so that is why I have FF Remember History.

Is there a way to set up FF to remember the sign-in information but not remember the other browsing history so it 'fills up' my machine and slows it down? I really hope that there is but it is not obvious to me.

Thanks in advance for your help!

All Replies (17)

more options

Hi RHB10, what method are you using to clear history when closing Firefox? If you mean the checkbox on the Options page, to its right there is a "Settings" button that lets you choose what to clear. Most sites will preserve your login information in Cookies; some may use Offline Website Data. If you store any site-specific preferences such as popup permissions or notification blocks, then make sure not to clear Site Preferences, either.

Does that make sense?

more options

Hi J,

I have attached a screen shot of how my Options are set. This remembers the history and login in information and then deletes the history when I exit FF.

However the problem is that I do so much browsing that remembered history gets so big everything comes to a standstill. At this point I have to bookmark the open tabs, shutdown FF and restart it. When I uncheck Remember browsing and download history then FF doesn't remember my automatic logins.

In my mind what I am looking for is to find a way to have FF remember my automatic login information and not remember all the rest of the history. In that way I will have the automatic login information and not have to shutdown and restart FF when the remembered history is too big.

I hope that makes sense and you can help me find a solution.

Thanks in advance!

more options

Hi RHB10, in the lower right of your screenshot, you can see the "Settings" button I was talking about.

jscher2000 said

Hi RHB10, what method are you using to clear history when closing Firefox? If you mean the checkbox on the Options page, to its right there is a "Settings" button that lets you choose what to clear. Most sites will preserve your login information in Cookies; some may use Offline Website Data. If you store any site-specific preferences such as popup permissions or notification blocks, then make sure not to clear Site Preferences, either.
more options

Hi J,

I have attached a screen capture of the Settings I currently have.

So now what do you suggest?

Thanks in advance!

more options

Hi RHB10, what you have should preserve persistent cookies.

Further up the page, in the Cookies and Site Data section, do you have the box checked for

[_] Delete cookies and site data when Firefox is closed

If that box is checked, all cookies are scheduled to expire at the end of the session, so even if they are not cleared by the

[_] Clear history when Firefox closes

feature, they will be gone due to natural expiration.

If you want to use "Delete cookies and site data when Firefox is closed" but you want to keep persistent cookies for some sites, you need to create exceptions for those sites.

To do that, you can either use the "Manage Permissions" button right there, or create exceptions while you are on the site using the Page Info dialog. Either:

  • Ctrl+i (for Mac, Command+i)
  • right-click a blank area of the page > View Page Info
  • (menu bar) Tools > Page Info

When the dialog comes up, click the Permission icon at the top to show that panel.

Cookies - Scroll down to "Set Cookies" and uncheck the "Use default" box, and then select Allow to let the site set persistent cookies.

more options

Hi J,

I do not have the Delete cookies and site data when Firefox is closed box checked.

Now that all of that is established. Is there something else to do to stop FF from accumulating the History until it is closed? That is my original question. I really don't want to stop working bookmark the tabs I am working on and then restart FF to clear the accumulated history. In plain english I am looking for a way to have FF stop saving history while I am working and thus avoid having to shutdown FF and restart it.

Thanks for your help!

more options

It looks from your last screenshot like you already unchecked the box for storing history as you browse (behind the Settings box):

[_] Remember browsing and download history

Firefox still stores history?

more options

By the way, there is a similar feature called Clear Recent History that you can use to clear history instead of restarting. This also removes session history, so Restore Previous Session will not be an option.

You can call that up using Ctrl+Shift+Delete or

  • menu button > Library > History > Clear Recent History
  • (menu bar) History > Clear Recent History
more options

Hi J,

Ah yes FF remembers the history until I 'run out of room' and then am forced to shutdown and restart FF. I tried the Clear Recent History however it takes 4 times linger that shutting down FF and restarting.

This is a real problem for me. The way I look at it there should be a setting that will remember the login settings and form history and NOT remember the other browsing history.

Maybe you can either figure out what is going on and get a solution started.

Thanks for your help.

more options

Maybe the problem is not history -- literally URLs and times visited -- but the web cache? If you have a reasonably fast connection, you could try disabling the disk cache and seeing what effect that has on your Firefox:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste cache and pause while the list is filtered

(3) Double-click the browser.cache.disk.enable preference to switch the value from true to false

Alternately, there might be a way to force it to use less disk space, although I can't recall the settings for that.

more options

Did you check for issues caused by security software ?

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

more options

Hi Cor-el,

Tried that but it didn't help.

Thanks

more options

Hi J,

I disabled the cache and that helped, however, ultimately had to SD and Restart FF.

Surely I cannot be the only one with this issue...

I am using a brand new Del Laptop with W10, 8GB Ram.

Any more thoughts?

Thanks in advance for your help!

more options

Why did you have to restart Firefox? I assume it wasn't because you ran out of disk cache space. Is it a problem with memory?

more options

Hi J,

After 9 hours of continuous browsing use FF slowed down so much that it was unusable. After the restart it was running like a scared rabbit.

more options

Okay, next time, try some of the tricks in the following articles to see whether they make any difference:

more options