Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

firefox mark all website using innsecure connection, including github and google.

more options

firefox mark every website as insecure when http2 is enabled in about:config if http2 is disabled, everything is fine. its happen since long time ago. i think its kind of bug so i did not upgrade it till now. and still exists. -

firefox mark every website as insecure '''when http2 is enabled in about:config''' if http2 is disabled, everything is fine. its happen since long time ago. i think its kind of bug so i did not upgrade it till now. and still exists. -

Isisombululo esikhethiwe

In Firefox, I think http2 is an add-on on spdy, not an independent feature.

The NS_ERROR_NET_INADEQUATE_SECURITY code may indicate that a man-in-the-middle does not support the small cipher suite used for HTTP/2. I don't know what else could cause that message.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (4)

more options

Hi boku, what's the error code you get? It looks a bit like SEC_ERROR_BLAH_BLAH, and might not be visible until you click the Advanced button. (How to troubleshoot security error codes on secure websites)

Do you connect to those sites through a proxy or filter or other "man in the middle"? If so, it may not be up-to-date with the different encryption ciphers used by HTTP2 connections.

more options

i do both proxy and without. and the result are the same. also, i tried disable SPDY and re-enable http2 and everything works fine. i didn't understand the problem.

more options

the problem only happen if http2 and spdy both enabled. but its the default setting. both spdy and http2 are enabled by default. this never happen before.

Okulungisiwe ngu boku

more options

Isisombululo Esikhethiwe

In Firefox, I think http2 is an add-on on spdy, not an independent feature.

The NS_ERROR_NET_INADEQUATE_SECURITY code may indicate that a man-in-the-middle does not support the small cipher suite used for HTTP/2. I don't know what else could cause that message.