Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Disable picture in picture completely

  • 10 uphendule
  • 2 zinale nkinga
  • 83 views
  • Igcine ukuphendulwa ngu cor-el

more options

On multiple websites I visit, picture in picture happens automatically when I scroll past a video or click another section of a page. I find it highly annoying and distracting. I would like to disable it completely. How do I do this? I'd appreciate an answer that isn't too technical. Thanks.

All Replies (10)

more options

To clarify, what you've described is not picture-in-picture.

Picture-in-picture is a Firefox feature that allows you to display a video in a section of your screen, even if you minimize the Firefox window. It appears on top of other windows that you have open on your computer, even non-Firefox ones.

What you've described is a annoying, but it's the way that the website is designed. Unfortunately, since the code for each website is different, I'm not aware of any method that will work to block this design choice across all websites.

more options

You can look at media.autoplay prefs on the about:config page to see if these values work for you to block autoplay.

  • media.autoplay.default = 5 [0:allow; 1:blockAudible; 2:Prompt; 5:blockAll]
  • media.autoplay.blocking_policy = 2
  • media.autoplay.allow-extension-background-pages = false
  • media.autoplay.block-event.enabled = true

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

more options

Given the issue didn't start until after Firefox introduced picture in picture, I can't attribute it to the various web sites. I attribute it to Firefox.

co-rel, if I understood anything you said, I'd try it lol.

more options

The video popouts on websites has existed long before the picture in picture feature with the blue box on video.

more options

How on hell can I deactivate these pics in pics than hide part of the screen and make it darn difficult to read anything? Part of it is under FF resposibility: it only happened after an update about 6 weeks ago. The advice to deactivate is not well written and does not work Presently I am looking for another browser and will abandon FF altogether because these pics in pics are so annoying

As a general ruee I hate al theses apps that disturb what I am reading and prevent me from concentrating on what I am interested in.

Might I have an answer from Moz? Tks

more options

There's a difference between picture-in-picture and a website just playing some content in the corner of the screen. Picture-in-picture isn't activated unless you actually press the blue button on the screen to activate it and it can be dragged around the screen.

In the settings, there is a checkbox to enable/disable picture-in-picture but that will only disable the picture-in-picture that's part of Firefox, not whatever other content websites are putting on the screen.

Modifying or filtering a website's content is not Firefox's responsibility. It just displays what the website tells it to display.

The fact that it only started happening after an update is purely coincidental and you'll have the same issue on other browsers because it's the content of the website that's the problem, not a browser feature.

more options

I have the same problem. A website shows a video within an article, which is fine. After scrolling down, the area where the video was playing is grayed out, and shows the message "Video playing in picture-in-picture mode", and the video moves to the bottom-left, blocking the text of the article. The video stays at the bottom-left of the screen if I scroll down further, and keeps blocking the text.

The option to disable picture-in-picture as shown in https://support.mozilla.org/en-US/kb/turn-picture-picture-mode does not exist in my firefox version (84.0.2 64-bit Windows 10). Instead it shows the option "Beheer media via toetsenbord, headset of virtuele interface", which translates to "Manage media via keyboard, headset or virtual interface". Maybe that is just a translation error, but disabling this option has no effect on the Picture-in-picture behavior.

An example of this behavior can be found with the first video on https://www.at5.nl/artikelen/206766/live-honderden-mensen-op-museumplein-gemeente-wil-demonstratie-ontbinden

This behavior is extremely annyoing. Is there really nothing that can be done against it, except switching to a different browser?

more options

Hi indestructium

The mini payer I see at the bottom left is not the Firefox PiP player, but is created by this website via JavaScript. If you hover that mini player window then you should see the Firefox PiP icon to confirm this. I can close the player window via close X in to top right corner of this mini player.


If you block Firefox auto-play then you shouldn't see this player appear unless you start a video.

You can look at these prefs on the the about:config page to see what settings work for you to block autoplay.

  • media.autoplay.default = 5 [0:allow;1:blockAudible;2:Prompt;5:blockAll]
  • media.autoplay.blocking_policy = 2
  • media.autoplay.allow-extension-background-pages = false
  • media.autoplay.block-event.enabled = true

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.


Okulungisiwe ngu cor-el

more options

Thanks for your response. That's unfortunate. Are there any plans to give the user control over this behavior? In the past, when websites started to tell browsers to open lots of new pop-up windows, browsers were modified with a user option to block popups. Something similar is desirable for these new video pop-up windows.

I assume right now the only way to fix this problem is to completely disable javascript for misbehaving websites?

more options

You only get such a sticky mini player if you start a video and scroll down the page. If you additionally open a Firefox PiP window via the icon that appears if you hover a video in this case then you get two mini players, one created by the website with the Firefox Pip icon and another created by Firefox with the actual video.

With the autoplay block settings via about:config I posted above you shouldn't get the mini player (I didn't get it when going to that page).