Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox fails to open up a PayPal "popup" window-let when trying to make a purchase from Steam

  • 6 uphendule
  • 1 inale nkinga
  • 12 views
  • Igcine ukuphendulwa ngu jscher2000

more options

Hi Forum Folke,

Trying to make a purchase from Steam; click, click, click, get to the payment page, where I select "PayPal" as the method of payment. Get another screen that confirms proceed with PayPal; I click on "OK," and nothing happens. What's *supposed* to happen is a little popup window should open up with the PayPal login, I log in, wade through the selections, and make the payment. What *actually* happens is nothing at all. Click on "OK," and there's this "blink" and that's it. No other change to the page I'm looking at, no PayPal, no nothing... and if I persist in trying, Steam gets all uppity and tells me I've been trying to make too many purchases, try again later. Chrome handles the above scenario without any problem whatever, so the problem is not with Steam, it's with FireFox. Where should I be looking or what should I be looking for that might be preventing FireFox from doing what it should be doing? Thanks... I'm not sure what system info you need to diagnose this issue; if you'll let me know I'll be happy to dig it up and provide it.

Oh, and I'm pretty sure I can rule out my anti-virus, as again, it lets Chrome do it without problem... just not Firefox. For what that's worth....

All Replies (6)

more options

Hi, try turning off 'Enhanced Tracking Protection' for that site (and each stage of the login/payment process) by clicking the shield icon at the left-hand end of the address bar while the page is loaded - Enhanced Tracking Protection in Firefox for desktop.

If that doesn't help, disable any ad blocker you may be using then reload the site.


Try deleting ALL references to the website in question. To do that, open the 3-bar menu > Library > History, then click the Show All History link at the bottom of the list to open the History-library window. Search for Steam by typing it into the Search History field in the top-right corner. Now in the search results, right-click on Steam, and select Forget About This Site. (Browsing and download history, cookies, cache, active logins, passwords, saved form data, exceptions for cookies, images and pop-ups for that site will be removed). Give it a few minutes to complete the deletion, then try the site (not from an old bookmark) again. More - Delete browsing, search and download history on Firefox.

If your question is resolved by this or another answer, please help other users by marking the best reply as Solved. Thank you!

Helpful?

more options

Hi Scribe,

Thanks for taking the time, and for the suggestions. I tried them all (at the same time: did the "forget about" thing, disabled the ad blocker, and turned off the tracker... and still no PayPal window opening up. Any other ideas? Other than using Chrome whenever I want to visit Steam?  :)

Helpful?

more options

When a pop-up is blocked by Firefox then you normally get a yellow notification bar at the top of the page or a pop-op blocked icon in the location bar.

You can check the Web Console for possible messages about this issue.

Helpful?

more options

Hi cor-el,

No, no indication of any problem, other than that nothing happens when clicking on the 'proceed' button. Just a quick 'blip' as the page refreshes, and I'm right back where I started from, sans PayPal window.

?Web Console? OK, never mind, I found it. I'm not a programmer or developer, just an end-user. I can see that it can show all kinds of "behind the curtain" stuff, but I'll have to do a *lot* of messing around to see how it all works. Thanks for the new toy!

Helpful?

more options

Best is to hide CSS errors in the console via its filter bar as there are usually a lot and are most of the time not important (hidden items possibly have a count appended).

See also:

Helpful?

more options

Hi kharrisma, two other notes:

(1) If you are getting opening followed by closing, check your add-ons. One of them might have an overly aggressive anti-popup feature.

(2) Firefox allows popups directly after a click, but in case the site needs permission, you can grant that using the Page Info dialog. Either:

  • Ctrl+i (for Mac, Command+i)
  • right-click a blank area of the page > View Page Info
  • (menu bar) Tools > Page Info

When the dialog comes up, click the Permission icon at the top to show that panel.

Popups - Scroll down to "Open Pop-up Windows" and uncheck the "Use default" box, and then select Allow to let the site open popups.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.