Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Blocked from Accessing the Wordpress Website

  • 12 uphendule
  • 1 inale nkinga
  • 18 views
  • Igcine ukuphendulwa ngu cor-el

more options

FF (78.0.2) will not allow me to visit wordpress.com. Below is a copy of the text on the error screen. There is not option to proceed, only to go back.

"Did Not Connect: Potential Security Issue

Firefox detected a potential security threat and did not continue to wordpress.com because this web site requires a secure connection.

What can you do about it?

wordpress.com has a security policy called HTTP Strict Transport Security (HSTS), which means that Firefox can only connect to it securely. You can’t add an exception to visit this site.

The issue is most likely with the web site, and there is nothing you can do to resolve it.

If you are on a corporate network or using anti-virus software, you can reach out to the support teams for assistance. You can also notify the web site’s administrator about the problem.

Learn more…

Someone could be trying to impersonate the site and you should not continue.

Web sites prove their identity via certificates. Firefox does not trust wordpress.com because its certificate issuer is unknown, the certificate is self-signed, or the server is not sending the correct intermediate certificates.

Error code: SEC_ERROR_UNKNOWN_ISSUER

View Certificate"

Okulungisiwe ngu justinpbrown

Isisombululo esikhethiwe

Hi Justin, I don't see why your Firefox can't verify that certificate.

I'm not sure this is necessary, but maybe check that the COMODO RSA Certification Authority has full trust. You can check that here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the left column, click Privacy & Security

On the right side, scroll to the bottom of the pane and click View Certificates to open the Certificate Manager dialog.

Click the Authorities tab and scroll down to the COMODO section. Click COMODO RSA Certification Authority and then click the "Edit Trust" button to confirm that both boxes are checked there. (First screenshot.)

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (12)

more options

You may need to wait for WordPress to get a valid certificate before that warning goes away.

Helpful?

more options

child_duckling said

You may need to wait for WordPress to get a valid certificate before that warning goes away.

Thanks for your response.

I can't even turn off the FF security to access the website. So I cannot even sign in to the account, unless I use a different browser? Why is this?

The Wordpress website is accessible using IE. DDG states that the site has a securely encrypted connection. I don't really understand exactly the situation.

Is it usual for such a high profile website to operate without such basic security measures in place?

Okulungisiwe ngu justinpbrown

Helpful?

more options

Hi Justin, if you click the "View Certificate" button/link on the error page, who is listed as the issuer? This s what I see:

Common Name COMODO RSA Domain Validation Secure Server CA

That refers to the identification of the signing certificate.

Since it's nearly impossible to paste from that page, I've attached a screeenshot.

Helpful?

more options

jscher2000 said

Hi Justin, if you click the "View Certificate" button/link on the error page, who is listed as the issuer? This s what I see: Common Name COMODO RSA Domain Validation Secure Server CA That refers to the identification of the signing certificate. Since it's nearly impossible to paste from that page, I've attached a screeenshot.

I saw this too. But what is the relevance? Is not COMODO a legitimate certification company? I have seen the COMODO website where these certificates can be purchased. I don't exactly know how this works. I am no clearer in my understanding.

Helpful?

more options

Okay, it's good that you are getting what seems to be a genuine certificate. I don't know why the verification of the chain of trust isn't working. Do you notice any differences compared with my earlier screenshot?

Helpful?

more options

There are no differences between the certificate I see & the part of the one you showed. I will attach all 3 pages of the one I see. (I have also tried opening FF in safe mode, same result.).

Okulungisiwe ngu justinpbrown

Helpful?

more options

Isisombululo Esikhethiwe

Hi Justin, I don't see why your Firefox can't verify that certificate.

I'm not sure this is necessary, but maybe check that the COMODO RSA Certification Authority has full trust. You can check that here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the left column, click Privacy & Security

On the right side, scroll to the bottom of the pane and click View Certificates to open the Certificate Manager dialog.

Click the Authorities tab and scroll down to the COMODO section. Click COMODO RSA Certification Authority and then click the "Edit Trust" button to confirm that both boxes are checked there. (First screenshot.)

Helpful?

more options

Also, if you haven't already, please try clearing Firefox's web cache: How to clear the Firefox cache

Helpful?

more options

jscher2000!!!!! Many thanks! That did it.

I have never been to those settings to edit them, so I have no idea why they were set that way. I have issues with some other sites too, so they might be remedied with similar adjustments...

I appreciate you sticking with me & providing a solution. You have my gratitude.

Have a great week!

Helpful?

more options

I also have this problem since today.

None of this problem exists on any other browser and I also had accessed wordpress websites before (as shortly as a few days ago. The recommended suggestions to tick a box on a certificate didn't help. Clearing cache didn't help either. I continue to get this on a blank page:


Secure Connection Failed

An error occurred during a connection to [any subdomain].wordpress.com.

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem.

Learn more…

Helpful?

more options

also digital-audio.org was not accessible (I got the exact same "secure connection failed" message yesterday. Today that website seems accessible. So now I have two days in a row that a legitimate site has been blocked by firefox. Something new is up.

Helpful?

more options

Hi jerriy

You can check details about the issuer of the certificate and the certificate chain.

  • click the "Advanced" button on the error page to show more detail
  • click the blue "View Certificate" text to inspect the certificate chain in the Certificate Viewer

Who is the issuer of the certificate ?

You can optionally attach a screenshot that shows the Wordpress certificate (i.e. first tab of the Certificate Viewer).

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.