Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Screen not displaying correctly but does in Edge and Chrome!

  • 16 uphendule
  • 2 zinale nkinga
  • 203 views
  • Igcine ukuphendulwa ngu rhz

more options

There is a website that I used today and discovered that it does not display correctly on Firefox although it displays correctly on Edge and Chrome.

I have attached screenshots of the webpage on all 3 browsers and you can see that the there are 2 ticks missing from the Firefox screen where the text says Available in-store at Karingal and at Pick up Avaliable.

I tried running Firefox in Safe Mode but it still did not show this screen correctly.

I am running Firefox for Desktop version 78.0.2 (64-bit).

Any suggestions on what is causing this and a solution would be helpful.

Thanks.

Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

That is a problem with this website.

There are actually three affected images, also one at the top before "Pick up".

There is a stray </defs> line in the icons-sprite.svg file that is used for these images:

    </symbol>
    </defs>
    <symbol id="icon-blip" viewBox="0 0 32 32">
      <path xmlns="http://www.w3.org/2000/svg" d="M16 8c-3.093 0-5.6 2.479-5.6 5.537 0 4.442 5.6 11.263 5.6 11.263s5.6-6.369 5.6-11.263c0.001-3.058-2.507-5.537-5.6-5.537zM16 16c-1.326 0-2.4-1.074-2.4-2.4s1.075-2.4 2.4-2.4c1.326 0 2.4 1.074 2.4 2.4s-1.074 2.4-2.4 2.4z"></path>
    </symbol>

If I remove this line then I see the images.
Firefox is less forgiving for such errors than other browsers.
You can contact the website and ask them to look into this.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (16)

more options

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop

Helpful?

more options

I mentioned in my post that I already tried running Firefox in Safe Mode, as that's the first thing I tried, but it still did not show this screen correctly.

Thanks for the suggestion.

Helpful?

more options

And what about tracking protection?

Helpful?

more options

I turned tracking protection off but it is still not showing the screen correctly.

Helpful?

more options

Hi, i think I can confirm that similar things happen to me, https://support.mozilla.org/en-US/questions/1296070

Sorry for the duplicate, attached is gmail site with missing icons..

Helpful?

more options

Additional screenshot for website not shown correctly. The left navigation bar is suddenly disappear today!

Helpful?

more options

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Helpful?

more options

I have done more testing of this problem and here is what the results are:

1) I started my laptop (Dell) in safe mode with networking and the problem is still there.

2) I started my wife's laptop (Toshiba) in "normal" mode and the problem was there in Firefox but not in Edge or Chrome.

   I started her laptop in safe mode with networking and the problem is still there.

3) I asked my daughter to check this problem on her laptop (HP) and she also had the problem in Firefox.

   She started her laptop in safe mode with networking and the problem is still there.

I would think that we can conclusively say that Firefox is the problem here.

I will now try installing previous older versions of Firefox to see which version created the problem.

Helpful?

more options

Isisombululo Esikhethiwe

That is a problem with this website.

There are actually three affected images, also one at the top before "Pick up".

There is a stray </defs> line in the icons-sprite.svg file that is used for these images:

    </symbol>
    </defs>
    <symbol id="icon-blip" viewBox="0 0 32 32">
      <path xmlns="http://www.w3.org/2000/svg" d="M16 8c-3.093 0-5.6 2.479-5.6 5.537 0 4.442 5.6 11.263 5.6 11.263s5.6-6.369 5.6-11.263c0.001-3.058-2.507-5.537-5.6-5.537zM16 16c-1.326 0-2.4-1.074-2.4-2.4s1.075-2.4 2.4-2.4c1.326 0 2.4 1.074 2.4 2.4s-1.074 2.4-2.4 2.4z"></path>
    </symbol>

If I remove this line then I see the images.
Firefox is less forgiving for such errors than other browsers.
You can contact the website and ask them to look into this.

Okulungisiwe ngu cor-el

Helpful?

more options

I understand what you are saying but if I contact the company about this issue I know exactly what they will say..."Use Chrome or Edge as you said that they work okay!"

I'm sure you are aware that these companies generally take the easy option so rather than fix and test this amendment to their coding so that it works on Firefox, they will simply say use another browser that works!

So this doesn't solve the problem with Firefox, it only encourages more people to stop using it and use Chrome or Edge or other browsers that don't have problems.

Helpful?

more options

They sell things, so I would assume that they do not want to lose customers because of an error that is easy to fix with a minor edit.

Helpful?

more options

What browser version are you running and what device is it on as the extra detail in your 3rd image, Pairs well with chicken and the knife & fork icon are not on the screenshots I posted using Chrome or Edge?

Helpful?

more options

I appear to have picked another product. That would also explain why this item isn't in store.

I've replaced the third image with what is probably the correct item.

Helpful?

more options

Helpful?

more options

I have logged an issue with the company and hopefully they will contact me and I can provide them with your fix so I will flag your reply as solving the problem.

Many thanks for your help.

Helpful?

more options

cor-el said

@ rhz Could you please start a new thread for your question?

I have started my own thread with no reply. The second link is also broken

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.