Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Upgraded to TB 78.0 - no colored folders under Local Folders and Composition/View Panes are dark.

  • 68 uphendule
  • 7 zinale nkinga
  • 662 views
  • Igcine ukuphendulwa ngu Toad-Hall

more options

Hi all -

Just upgraded to TB 78 on Windows 10 x64, Build 2004. Noticed two major things:

Issue 1 -

All of the mail folder icons are no longer yellow. Just a stark white with a black edge. I attached an Image of the issue for review.

Issue 2 -

My Message Composition Pane is dark with white letters and most incoming text mail is the same.

I do have some dark colors set up under PC Settings -> Personalization but everything was working perfectly prior to this new release.

I attached Images of the issue for review. Note the "dark haze" over the HTML email.

No add-ons are enabled!

Any help appreciated! Kind of urgent to me.

TIA :)

Ama-screenshot ananyekiwe

All Replies (20)

more options

Question...

When might this problem be totally resolved?

Thanks. :)

Helpful?

more options

re :Issue 1 - All of the mail folder icons are no longer yellow. Just a stark white with a black edge.

I believe you have already been offered an answer for this, but just in case you have forgotten...

The previous icons were PNGs, not scalable which caused various issues for people. The new icons are Photon icons and come only with the thick outline. They are used generically throughout Thunderbird. Photon icons have been designed to be scalable and the developers have managed to include an option to choose whatever colour you want. This a new option.

  • Right click on folder and select 'Properties'
  • Under 'General Information' tab
  • For 'Icon Colour' - click on rectangle colour box
  • choose colour, click on ok
  • click on OK

Helpful?

more options

re :Issue 2 - My Message Composition Pane is dark with white letters and most incoming text mail is the same.

The most reason Version: 78.1.0 The developers have been looking for a solution and now the Message Pane and 'Compose' area in 'Write' window are using a light background. Suggest you update to 78.1.0

Helpful?

more options

I am on the latest release of TB.

One thing that I hate is those Photon icons, which make TB look like an unfinished product.

There aren't really any nice themes that take advantage of them, AFAIK. Why cant all the icons be solid? Or even textured?

Just looking now for a fix for the HTML issue and I'm good to go.

Thanks for all your help! :)

Okulungisiwe ngu Compumind

Helpful?

more options

sfhowes said

The blurry text is due to a non-default theme (see pictures).

Gotcha, that fixes my problem so thanks for that!

Helpful?

more options

Another issue -

The Photon icons soon lose their color that I have assigned. This is the second time it has happened.

Does anyone else see this?

)

Helpful?

more options

Earlier in this conversation, it was mentioned that Windows OS has an 'app mode'. You said: Then I set the system theme to Dark in Personalization -> Colors (choose your color) -> Dark.

However, to set the 'app mode', you need to select: Then I set the system theme to Dark in Personalization -> Colors (choose your color) -> 'Custom'. This will then show you the default Windows mode as a separate thing from default app mode. You do not appear to have mentioned this. For example: you could set Windows mode as light and app mode as dark.

I have set both Windows mode and windows app mode to dark. I have also set thunderbird to use dark mode - not light nor default themes. I have also updated from 78.0.1 to 78.1.0 and when I updated the Message Pane and Write compose changed to use the light theme.

You mention I am on the latest release of TB., but is that 78.1.0 (not 78.0.1), there has just been a new update which fixes the Message Pane issue. The numbers are very similar :)


Regarding icons losing colour: Does this occur when you exit and reopen Thunderbird ? If yes. Are you using a product that cleans up files like CCleaner or is the Anti-virus set up to do same sort of thing ? If yes, then you need to make Thunderbird files and folders exempt from access because clean up products have a habit of cleaning up eg: session files before the data can be stored correctly.

Helpful?

more options

Toad-Hall said

Earlier in this conversation, it was mentioned that Windows OS has an 'app mode'. You said: Then I set the system theme to Dark in Personalization -> Colors (choose your color) -> Dark. However, to set the 'app mode', you need to select: Then I set the system theme to Dark in Personalization -> Colors (choose your color) -> 'Custom'. This will then show you the default Windows mode as a separate thing from default app mode. You do not appear to have mentioned this. For example: you could set Windows mode as light and app mode as dark. I have set both Windows mode and windows app mode to dark. I have also set thunderbird to use dark mode - not light nor default themes. I have also updated from 78.0.1 to 78.1.0 and when I updated the Message Pane and Write compose changed to use the light theme. You mention I am on the latest release of TB., but is that 78.1.0 (not 78.0.1), there has just been a new update which fixes the Message Pane issue. The numbers are very similar :) Regarding icons losing colour: Does this occur when you exit and reopen Thunderbird ? If yes. Are you using a product that cleans up files like CCleaner or is the Anti-virus set up to do same sort of thing ? If yes, then you need to make Thunderbird files and folders exempt from access because clean up products have a habit of cleaning up eg: session files before the data can be stored correctly.

Sorry about the version transposition, it is 78.1.0, lol.

It does occur when I use CCleaner, now that I think about it. IMHO, those color settings should be exempt from normal CCleaner activity.

How can I exclude just the Proton areas which get deleted? (i.e. folder colors have been purged.)

Thanks again! :)

Helpful?

more options

Ideally, you do not want CCleaner to scan etc any folder or file in Thunderbird. There are various files eg: password files, session files etc that are contained in 'profile name' folder, Gmail needs cookies to be functioning if you have a gmail account. If anything in Thunderbird gets removed it can cause issues that mainly are a nuisance. Updated data in a session file is often updated to other files and preferences when Thunderbird is exited.

If thunderbird profile is in the default location, then it will be here:

  • C:\Users\<Windows user name>\AppData\Roaming\Thunderbird\Profiles\<Profile name>\

'Profile name' folder is usually xxxxxxxx.default or xxxxxxxx.default-release, where the x's are various letters and numbers.

The link below does say that CCleaner will exclude folders; some products only exclude files which is a pain to set up as there are so many. Info on CCleaner excluding folders: https://www.ccleaner.com/docs/ccleaner/using-ccleaner/excluding-files-folders-and-registry-entries

Suggest you try excluding the 'Thunderbird' folder which is in 'Roaming' folder.

Helpful?

more options

re :Regarding icons losing colour:

Now go figure this..it's just happened to me. I removed an account and then reinstalled it and guess what happened to all the colours previously set up :)

So, did you by any chance add or remove and add, a mail account ?

Helpful?

more options

Toad-Hall said

re :Regarding icons losing colour: Now go figure this..it's just happened to me. I removed an account and then reinstalled it and guess what happened to all the colours previously set up :) So, did you by any chance add or remove and add, a mail account ?

Not at all. Also tried CCleaner on a default Custom Clean and the icons are still colored.

Another Bug to open, please, lol.

)

Helpful?

more options

Toad-Hall:

I noticed the same thing: color for the folder icons got wiped and I just updated from 78.0.1 to 78.1.0. So yeah it lost that configuration on the update.

Toad-Hall said

re :Regarding icons losing colour: Now go figure this..it's just happened to me. I removed an account and then reinstalled it and guess what happened to all the colours previously set up :) So, did you by any chance add or remove and add, a mail account ?

Helpful?

more options

The non-migration of the colors from 78.0.1 to 78.1 is mentioned in the release notes.

Helpful?

more options

According to info in the bug report, it was a one time architectural change and not expected in a future upgrade.

Helpful?

more options

Not sure that that means. As long as it doesn't mean removing the ui.systemUsesDarkTheme set to 1 that you mentioned that solved the issue, I'm fine with that.

BTW, I set it now to 0 with TB 78.1.0 and I'm glad to see the email preview doesn't attempt to use dark mode, but the new email composition window does, which can still be awkward if you're replying to an email that doesn't render correctly under dark mode.

Toad-Hall said

According to info in the bug report, it was a one time architectural change and not expected in a future upgrade.

Helpful?

more options

I did notice that, I was just curious why those coloring preferences were gone when updating from 78.0.2 to 78.1.0. Since I only changed the color for a handful of the many custom folders I have, no big deal, but if someone had taken the time to painstakingly color each of their folders, only to see their work undone, that would be off-putting.

sfhowes said

The non-migration of the colors from 78.0.1 to 78.1 is mentioned in the release notes.

Helpful?

more options

The new darker outline of the folder outlines in the folder pane and the darker collapse/expand arrow make it much harder to notice when a folder is bold (unread mail) or bold and blue (unseen/unread). If the arrows and outlines were narrower or a lighter grey, that would probably be ok, but as it is I have to work harder to see which folders have new mail that I need to check.

Helpful?

more options

I just posted this in another thread:

This problem only happened to me over night with update to 78.2.1! Giving the black background for a new message and then the white text on white in the messages, correspondents etc columns. That changes to black once it turns to read. I've changed it in defaults but it doesn't stay, just goes right back as soon as you try and compose a new message or forward one on.

I'm not wanting to change my theme in windows to light! Surely there's been a fix for this issue by now without doing that?

Helpful?

more options

CH I've updated to 78.2.1 and do not have any problem as it was fixed a couple of version ago. These are my settings: Windows OS:

  • In Settings >Colours
  • Choose your colour - select 'Custom'
  • The default Window mode is Dark.
  • Windows default app mode is Dark.

In Thunderbird:

  • Menu app icon > Addons > Themes
  • The enabled theme is 'Dark' .


  • Menu app icon > Options > General
  • scroll down to 'Language & Appearance' section
  • click on 'Colours..' button

Text and Background

  • Text is black
  • Background is white
  • 'Use system colours' checkbox is Not selected

'Override the colours specified by the content with my selection above'

  • Choose either 'Only with High contrast themes' OR 'Never'.

If set to 'Always' you will find various tabs will open with a White background even if set to use Dark theme.

  • Click on OK
  • Menu app icon > Options > Composition

HTML Style section

  • Font 'Variable width
  • Size: Medium
  • Text Colour: Blue
  • Background Colour: White

If you select 'Use Readers default colours' checkbox: Composing messages in Write window Result: White text on Black background.

If you do NOT select checkbox for 'Use Readers default colours' Composing messages in Write window Result: Blue text on White background.

Helpful?

more options

And to add to my previous comment this is my current setting in the 'about:config'

  • Menu app icon > Options > General
  • scroll to the bottom and click on 'Config Editor' button
  • It will say be careful :)
  • In search type: UsesD
  • Look for this line: ui.systemUsesDarkTheme
  • Mine is set to number 1 (The 0 setting is not longer required due to fix)
  • Close 'about:config' - top right x

Helpful?

  1. 1
  2. 2
  3. 3
  4. 4
Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.