Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox blocking linked images on discussion forum

  • 1 baphendule
  • 1 inale nkinga
  • 3 views
  • Igcine ukuphendulwa ngu jscher2000

more options

When I post links from Twitter, Instagram and Imgbb.com to a discussion forum that I belong to, the images are blocked when I am using Firefox for Windows. This is a very recent problem (just the past week or so). I have no problem seeing the images using Firefox for Android on my phone or Microsoft Edge.

I recall there being an update a week or so ago, so I am wondering if it has something to do with that. Did it change one of my settings?

Thank you,

Jodi

All Replies (1)

more options

Hi Jodi, is the Enhanced Tracking Protection shield icon turning purple on that site? If so, please check that see whether it is blocking those images. You can click the shield and it will list what it is blocking, and also has a button to turn off ETP for the site to see whether that makes any difference.


If this is not the general experience of users on the forum, these are standard suggestions to try when a site stops working normally:

Double-check other content blockers: Extensions that counter ads and tracking, may break websites that embed third party content (meaning, from a secondary server). These include Adblock Plus, Blur, Disconnect, DuckDuckGo Privacy Essentials, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page.

There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that.

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.