Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Get Messages - how do I exclude an account?

  • 5 uphendule
  • 1 inale nkinga
  • 214 views
  • Igcine ukuphendulwa ngu retired74

more options

I have several email accounts and use Thunderbird as my mail collector. I am now trying to exclude certain accounts from the "Get Messages" option. There used to be a setting under account settings ''''account settings/server settings/advanced…/include this server when getting new mail.''' but this no longer seems to exist. (I'm using TB 68.9.0 on MacOs) Is there another way to do this? (It's probably obvious but I cannot find it!!)

I have several email accounts and use Thunderbird as my mail collector. I am now trying to exclude certain accounts from the "Get Messages" option. There used to be a setting under account settings '''''''''account settings/server settings/advanced…/include this server when getting new mail.'''''''' but this no longer seems to exist. (I'm using TB 68.9.0 on MacOs) Is there another way to do this? (It's probably obvious but I cannot find it!!)

Isisombululo esikhethiwe

I've attached an image. Wording has slightly altered in more recent versions but it is in the same location.

  • account settings > server settings for the specific pop account
  • click on 'advanced'
  • uncheck checkbox: 'include this server when getting new mail'.
  • Click on OK
  • Click on OK
  • Restart Thunderbird.


If you are not seeing basically the same as image below, please post an image so we can see what you see. If not sure how, info at link may help.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (5)

more options

I am not aware of that option, but another way you can achieve this is by changing the incoming server name to something else, for example localhost. All attempts to reach that server will fail, but a notification to that effect will show up each time an attempt to check for messages is made. You can lessen how often that attempt is made by disabling the checking of messages at startup for that account, and the periodic checking of new messages.

more options

retired74

re: Unfortunately the option 'account settings/server settings/advanced…/include this server when getting new mail. doesn't appear in my account settings box

That option would only appear if you are talking about a POP mail account and it would only be used if you were settings up POP mail accounts as deferred mail accounts aka 'Global Inbox' accounts which use 'Local Folders' Inbox.

I think you are talking about an IMAP mail account. Imap mail accounts store emails on the server. You can download headers or full copies of emails. You can set this up on a per folder basis. Please note: do not assume emails displayed in an imap mail account are separate from the server because imap folders synchronise with server. The folders are in effect one and the same.

Suggest you read info on IMAP mail accounts.

  • Account settings > Server Settings
  • uncheck checkbox 'Check for new messages at start up'
  • uncheck checkbox 'Check for new messages every xx minutes'
  • uncheck checkboc 'Allow immediate server notifications when new messages arrive'.
  • Click on 'OK
  • Restart Thunderbird to force those settings to be used in current session.

Please note: if IDLE process is used by the server, then server can attempt connection with imap account to download email regardless. IMAP accounts are designed to show what is on server.

more options

Toad-Hall said</p>

That option would only appear if you are talking about a POP mail account and it would only be used if you were settings up POP mail accounts as deferred mail accounts aka 'Global Inbox' accounts which use 'Local Folders' Inbox.

Hi Toad-Hall, I definitely only use POP accounts which all use "Local Folders" Inbox. In the past I have successfully excluded certain accounts from the "Get Messages" button but cannot find how I did it!! Thanks for your reply tho.' Best regards.

more options

Isisombululo Esikhethiwe

I've attached an image. Wording has slightly altered in more recent versions but it is in the same location.

  • account settings > server settings for the specific pop account
  • click on 'advanced'
  • uncheck checkbox: 'include this server when getting new mail'.
  • Click on OK
  • Click on OK
  • Restart Thunderbird.


If you are not seeing basically the same as image below, please post an image so we can see what you see. If not sure how, info at link may help.

more options

Aha!! I have found the tickbox. It is tucked away behind the "advanced" button in the "Message Storage" options. I had been looking for it in the Server Settings area. All sorted now. Thanks