Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox cannot connect to youtube? if it manages to connect to youtube the channel logos may not appear and same goes with the thumbnails of videos

  • Akukho zimpendulo
  • 1 inale nkinga
  • 1 view
more options

I have no idea what is causing this to happen. It is also affected when connecting to google. It starts either after browsing for some time or having my computer wake up from sleep. Edge does not have this issue. The scenarios trigger it: youtube is in a tab and after a while I switch back and refresh it and have channel logos and/or thumbnails blank, opening a video in private mode and not connecting while normal does or vice-versa, not connecting after waking up from sleep and not opening in either normal or private mode.

The only way to fix it is through restarting the computer.

Also youtube seems to forget my autoplay setting when this situation appears.

I have tried disabling ublock origin and tracking protection to no avail.

The same settings are applied on another computer and that computer has no issues.

V 77.0.1. Windows 10

This is the message I get: Hmm. We’re having trouble finding that site.

We can’t connect to the server at www.youtube.com.

If that address is correct, here are three other things you can try:

   Try again later.
   Check your network connection.
   If you are connected but behind a firewall, check that Firefox has permission to access the Web.

Okulungisiwe ngu IneedhelpwithFirefox

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.