Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

A web page is slowing down your browser.

  • 2 uphendule
  • 1 inale nkinga
  • 6 views
  • Igcine ukuphendulwa ngu CiaoBella1

more options

FF 77.0.1 W10.

I get this message on one specific website, every time I visit. It happens on other pages, but not continually, and not regularly.

Is there a remedy? Updated recently and do not want to have to reset or do anything drastic.

Asked this two other times, but I tagged on to previous conversations. Unfortunately, I did not get the usual prompt response.

Thank you.

FF 77.0.1 W10. I get this message on one specific website, every time I visit. It happens on other pages, but not continually, and not regularly. Is there a remedy? Updated recently and do not want to have to reset or do anything drastic. Asked this two other times, but I tagged on to previous conversations. Unfortunately, I did not get the usual prompt response. Thank you.

Isisombululo esikhethiwe

hello CiaoBella,

follow the steps:

Clear the cache

  • Click the 3 horizontal line top right and select Options.
  • Select the Privacy & Security panel.
  • In the Cookies and Site Data section, click Clear Data.

Goto safe mode

  • Click the 3 horizontal line top right and select Options.
  • Click new Private window or(ctrl+shift+p)

tell me its help

Thank you!

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (2)

more options

Isisombululo Esikhethiwe

hello CiaoBella,

follow the steps:

Clear the cache

  • Click the 3 horizontal line top right and select Options.
  • Select the Privacy & Security panel.
  • In the Cookies and Site Data section, click Clear Data.

Goto safe mode

  • Click the 3 horizontal line top right and select Options.
  • Click new Private window or(ctrl+shift+p)

tell me its help

Thank you!

more options

I had to wait until the site was live to test it. Instead of going into safe mode, I selected the addon that I suspected might cause an issue. I disabled it before I accessed the website and did not get the message.

So, thank you for the reminder.