Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Apple Mac Catalina 10.15.5

  • 5 uphendule
  • 2 zinale nkinga
  • 137 views
  • Igcine ukuphendulwa ngu cor-el

more options

G'day, I just got a Mac, Catalina 10.15.5, I've installed Firefox 3 times but every time I put the Mac to sleep Firefox is gone along with all info. Baffled???

Isisombululo esikhethiwe

The installer on Mac works very differently than Windows, and it sometimes seems you get a temporary install. Could you try the steps in the following article and see whether they work: How to download and install Firefox on Mac.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (5)

more options

Isisombululo Esikhethiwe

The installer on Mac works very differently than Windows, and it sometimes seems you get a temporary install. Could you try the steps in the following article and see whether they work: How to download and install Firefox on Mac.

Helpful?

more options

Make sure you install Firefox properly and that you do not run Firefox from within the DMG (Disk Image) file.

Open the Firefox Disk Image file and drag the Firefox application to the Applications folder on your hard drive.
You shouldn't double-click the Firefox application to run it from the Disk Image, but instead drag it out of the DMG folder.

Helpful?

more options

Hi jscher2000 & cor-el,

Cheers and thank you both very much for the replies it's very much appreciated. Every day something new will be learned!!!

Regards,

Puddle5OfMud!!!

Helpful?

more options

This did NOT help me. When I download Firefox, I don't get a firefox icon - only an old Apple note icon. I can't load the app, only run it from the dmg. This is very frustrating.

Helpful?

more options

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.