Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

getting blank page on startup instead of homepage

  • 29 uphendule
  • 2 zinale nkinga
  • 53 views
  • Igcine ukuphendulwa ngu Mark R

more options

getting blank page on startup instead of homepage

clicking on home button and ctrl + n brings me to homepage.

can u help me?

77.0.1 (64-bitars)

homepage: https://outlook.live.com/mail/inbox

getting blank page on startup instead of homepage clicking on home button and ctrl + n brings me to homepage. can u help me? 77.0.1 (64-bitars) homepage: https://outlook.live.com/mail/inbox

All Replies (20)

more options

hello voko6503,

follow the steps:

First save your home

new tab pages as you want them. Then do this

Firefox > Help > Restart With Add-ons Disabled (Safe Mode). Once the browser is open, check your page settings. Are they the way you want them?

tell me it helps.

Thank you!

more options

its working until i exit and reopen again.

Okulungisiwe ngu voko6503

more options

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

more options

I have this problem too. If I use safe-mode to start up my home page loads correctly. However, even if I disable all my add-ons I still have a blank page on start up. I have followed the link above and tried all the steps suggested. I do not have ADvanced SystemCare or any of the other programmes listed.

Any help in resolving this will be appreciated. Thanks.

more options

https://support.mozilla.org/en-US/kb/how-to-set-the-home-page

Type about:config<enter> in the address bar.
If a warning screen comes up, press the I Accept the Risk button.
At the top of the screen is a search bar. Type browser.startup.homepage

What is the value?
Right-click and select Reset to restore its default value; about:home

more options

this is what i get

more options

Hi voko6503, I just wanted to mention that several Gmail users who set their home page to Gmail also reported problems with getting a blank page at startup. Clicking the Home button, launching a new window, all the other ways to open Gmail work fine, but it won't show at startup. Clearing Firefox's cache resolved the issue for one cycle, but the problem came back later. So far I have not seen anyone identify the culprit, whether it's an add-on, security program, or a bug in the cache. ??

more options

FredMcD said

https://support.mozilla.org/en-US/kb/how-to-set-the-home-page Type about:config<enter> in the address bar.
If a warning screen comes up, press the I Accept the Risk button.
At the top of the screen is a search bar. Type browser.startup.homepage What is the value?
Right-click and select Reset to restore its default value; about:home

Hi FredMcD.

The value under browser.startup.homepage is https://start.me/p/nRrMpL/startpage

Resetting doesn't help in that it just returns me to the Firefox homepage on start up. The problem is getting a different home page to run on start up. In my case the page I'm trying to run is my personalised page on Start.me.

This worked fine until a few weeks ago.

more options
more options

McCoy said

See :
https://support.mozilla.org/en-US/forums/contributors/714277?last=78907

...... and "the invisible post" showed up   (time stamp doesn't match reality, though)

more options

@ Chris242 :

In Options => Home you have used a custom URL and set start.me to be your homepage.
Yet, at startup Firefox opens Firefox Homepage.

When you start Firefox in Safe Mode, your homepage opens, but when you disable all add-ons, then at startup Firefox Homepage opens.

Is that a correct recap ?

more options

Yes, that’s right.

more options

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

more options

What are the settings of browser.startup.page and browser.startup.blankWindow on the about:config page ?

  • browser.startup.page [0:blank; 1:home page; 2:last visited page; 3:restore previous session]
more options

cor-el said

What are the settings of browser.startup.page and browser.startup.blankWindow on the about:config page ?
  • browser.startup.page [0:blank; 1:home page; 2:last visited page; 3:restore previous session]

browser.startup.page is at 1

browser.startup.blankWindow is at true (tried to change it, didnt help)

Okulungisiwe ngu voko6503

more options

chris242 said

If I use safe-mode to start up my home page loads correctly. However, even if I disable all my add-ons I still have a blank page on start up.

Anybody know what might cause it ?

(some add-ons, even though disabled, still cause problems .... )

more options

I do NOT have Advanced System Care. I have Norton Utils Prem. Either way, if something may be protecting Firefox settings from Changing, I have had the Current Home page set for YEARS, so it should STILL be a Setting. Only started happening a week or two ago. When I First start up Firefox (after turning on pc), I get my Homepage. If I close Firefox, then open it again, I get a Blank start page. Options shows my Homepage settings are Correct.

more options

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh).

Do this several times. Is the problem still there?

more options

Hi Mark, is your experience consistent with what other users reported (especially with Yahoo as their home page):

  • Home page doesn't show at startup, unless cache was cleared during the previous session
  • Home page loads normally when either clicking the Home button on the toolbar or launching a new window (Ctrl+n on Windows, Command+n on Mac)
more options

Been using Cnet.com as Homepage for YEARS. Only had this problem in last week or two. about:config shows correct page. Shows 1 to use that page. Only seems to happen AFTER starting pc, and closing Firefox, then re-opening. Have NEVER used Ctrl+n in Firefox. Did Not need to click on Home button. Was Just THERE when opened Firefox for First time. I have Windows 8.1. Been using Firefox for YEARS. Have NOT had to clear cache. Hmm... Did a "Clean" by Norton Utilities Premium make a change in Firefox startups? Just got that a week or two ago. Let it clear Temp/Junk files. An Advanced System Care screen that I saw, looked Very much like an Analyze screen from Norton Utilities Premium. Is there some type of "sync" with those programs?????

  1. 1
  2. 2