Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

PDFs print small in Firefox, works fine in Chrome

  • 12 uphendule
  • 1 inale nkinga
  • 645 views
  • Igcine ukuphendulwa ngu liz15

more options

Suddenly last week my PDFs started printing much smaller than normal. A letter size page prints about 6x9 instead of 8.5 x 11. Today I discovered that the same pages print fine in Chrome. Is there a known issue printing PDF files in Firefox? Is it being worked on? I love the browser and I refuse to use Chrome, but this is a big problem.

Isisombululo esikhethiwe

Hmm, does Firefox print the pages centered, like there are large margins all around, or in the upper left corner like print scaling is less than 100%? If it's in the upper left corner, although you said you already looked at scaling, could you double-check in about:config --

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste scaling and pause while the list is filtered

Each printer should have a print_scaling value of 1 (or possibly 1.00) to print at 100%.

That actually is in effect only if "Shrink to fit" is disabled....

(3) In the search box in the page, type or paste shrink and pause while the list is filtered

Each printer should have a print_shrink_to_fit value of true.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (12)

more options

You responded with a link to Firefox support, which requires a Google account. I don't have a working Google account. Is there a way to get support without using Google?

Helpful?

more options

Hit Alt, then open the File menu and open Page Setup.

Chances are that the zoom level or Scale is set to less that 100%. Although Shrink to fit should work fine for PDF files that are printed by Firefox. Once that setting is changed is remains at that level until it is changed again.

Helpful?

more options

I've tried changing every setting relating to size and nothing works.

Helpful?

more options

liz15 said

You responded with a link to Firefox support, which requires a Google account. I don't have a working Google account. Is there a way to get support without using Google?

That was a Fake support spam (now hidden) as this spammer used to post replies to fake support by phone numbers which is why we have the Beware of phishing attacks: banner on top now.

This place you posted this thread is the Official support for desktop Firefox.

Helpful?

more options

Hi liz15, just to confirm, you are printing a PDF displayed in a Firefox tab to a normal printer? Or you are printing a web page displayed in a tab to a PDF printer?

Firefox picks up paper size information for your printers from Windows, but occasionally there are glitches. Could you take a look under the hood here:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste paper_data and pause while the list is filtered

Firefox should display a list of all the printers it has stored paper information for, and the value for all of them should be 1 if their default paper size is letter.

(3) If the value of any of print.printer_printer_name.print_paper_data preference is something other than 1, double-click it to display an editing field, change the value to 1 and then press Enter or click the blue check mark button to save the change.

Any improvement so far?

Helpful?

more options

I am printing a PDF displayed in a Firefox tab to a normal printer. I just looked at the paper_data configuration and all printers are set to 1.

Helpful?

more options

liz15 said

I am printing a PDF displayed in a Firefox tab to a normal printer. I just looked at the paper_data configuration and all printers are set to 1.

Thank you for checking that.

I find that the PDF print fidelity is best if I open a PDF in Adobe Acrobat, outside of the browser, but that does take a little extra time.

When Firefox displays the Print dialog, can you click the Preferences button and see whether the printer is configured to use 6 x 9 paper instead of 8.5 x 11 paper?

Helpful?

more options

All printer settings are set to letter size. It's a pain to save files to print outside of the browser...I just don't have the extra time to do that. (this is for work, not pleasure)

Helpful?

more options

If Firefox knows it's letter-sized paper, and it's a letter-sized PDF, it's difficult to explain why it's not using the whole sheet.

You could check all the margin-related settings for that printer to see whether any look abnormal. In particular:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste print_ed and pause while the list is filtered

Normally, these print_edge values are all 0.

(3) In the search box in the page, type or paste print_un and pause while the list is filtered

Normally, the printer-specific print_unwriteable_margin values are all 0. If you wanted to reserve a quarter inch around the page that Firefox would not use, you could specify 25 (i.e., 25/100).

(4) In the search box in the page, type or paste print_mar and pause while the list is filtered

These are the same margin settings you set through the Page Setup dialog.

Helpful?

more options

Thanks. Here's what I found:

print_edge values are all 0 printer-specific print_unwriteable_margin values are not 0, but if they represent the numerator in a fraction over 100, they are not large enough to create this problem. (all of them are 17, except two that are 24) print_mar values are all .5

Any other ideas? This just recently started happening. Have there been any recent changes to Firefox? Why would it work OK in Chrome?

Helpful?

more options

Isisombululo Esikhethiwe

Hmm, does Firefox print the pages centered, like there are large margins all around, or in the upper left corner like print scaling is less than 100%? If it's in the upper left corner, although you said you already looked at scaling, could you double-check in about:config --

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste scaling and pause while the list is filtered

Each printer should have a print_scaling value of 1 (or possibly 1.00) to print at 100%.

That actually is in effect only if "Shrink to fit" is disabled....

(3) In the search box in the page, type or paste shrink and pause while the list is filtered

Each printer should have a print_shrink_to_fit value of true.

Helpful?

more options

BINGO!!!

print_scaling was set to .7 and print_shrink_to_fit was set to false. I changed both as you suggested, and it works now.

THANK YOU SO MUCH!!!

P.S. I wonder how those settings got changed; it sure wasn't me.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.