Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I disable the animation that occurs in a tab when a page is fully loaded?

  • 6 uphendule
  • 1 inale nkinga
  • 25 views
  • Igcine ukuphendulwa ngu Sigma

more options

I've just updated FF to version 77 and now I get an animation that occurs on a tab whenever a page is fully loaded in. See the attached image for what I mean.

How do I turn this off? Thanks.

Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

I found the answer to this elsewhere. In about:config you need to create ui.prefersReducedMotion and set its value to 1.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (6)

more options

Isisombululo Esikhethiwe

I found the answer to this elsewhere. In about:config you need to create ui.prefersReducedMotion and set its value to 1.

Helpful?

more options

Hi Steve, the blue swipe has been with us since Firefox 57, I think. I wonder how you turned it off before? Did you have a userChrome.css file?

I am not aware of a built-in setting for this, but you can hide the swipe using the following method. It's a little bit involved, so please set aside 10 quiet minutes to work through it.

(For anyone who already has a userChrome.css file set up, you just need to add the rules under (A) to your file.)

(A) Select and copy the following style rule code

/* No blue swipe on tabs when loaded */
.tabbrowser-tab .tab-loading-burst {
  display: none !important;
}


(B) Generate and download a userChrome.css file

Open the following page and paste the above rules into the editor, replacing the sample rule:

https://www.userchrome.org/download-userchrome-css.html

Then click "Generate CSS File" and save the userChrome.css file to your computer. (See first attached screenshot)

Use the downloads list on the toolbar to open the downloads folder directly to the new userChrome.css file. (See second attached screenshot)

Minimize that file browser window for later reference.

(C) Create a new chrome folder in your profile folder

The following article has the detailed steps for that (#1, #2, and I recommend #3)

https://www.userchrome.org/how-create-userchrome-css.html

I have videos for both Windows and Mac in case the text is not clear.

(D) Move the userChrome.css file you downloaded in Step B into the chrome folder you created in Step C

(E) Set Firefox to look for userChrome.css at startup -- see step #6 in the above article.

The next time you exit Firefox and start it up again, it should discover that file and apply the rules.

Success?

Once you start tweaking the interface this way, you'll probably find more and more things you want to do. I suggest bookmarking the pages where you get the code for future reference because changes to Firefox may break them and it's easier to request an update if you can find the source.

Helpful?

more options

Sigma said

I found the answer to this elsewhere. In about:config you need to create ui.prefersReducedMotion and set its value to 1.

Well, that's way easier. You should mark your reply as the solution!

Helpful?

more options

hi, sigma

you can disable that animation like this: enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named toolkit.cosmeticAnimations.enabled. double-click it and change its value to false.

i hope your question is fixed

Thank you!

Helpful?

more options

ARMAN KHAN said

you can disable that animation like this: enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named toolkit.cosmeticAnimations.enabled. double-click it and change its value to false.

Hmm, that doesn't work for me in Firefox 77 on Windows 10. Are you using the newest version yet?

Helpful?

more options

Thanks for the replies, guys.

I've had toolkit.cosmeticAnimations.enabled set to "false" since that animation was added, but that option no longer works in Firefox 77. I believe the animations are now linked to your Windows settings under Settings - Ease of access.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.