Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Slow opening of new tabs

  • 4 uphendule
  • 1 inale nkinga
  • 542 views
  • Igcine ukuphendulwa ngu mafinokc

more options

Firefox very slowly opens websites from other sources - Evernote, messenger, office word, PDF. It's not really the fault of a too slow laptop (i7-1065G7, 16 GB frame memory, SSD NVMe + current drivers).

It makes my work very difficult, is there any solutions?

Best Regards Rafał Kita

Firefox very slowly opens websites from other sources - Evernote, messenger, office word, PDF. It's not really the fault of a too slow laptop (i7-1065G7, 16 GB frame memory, SSD NVMe + current drivers). It makes my work very difficult, is there any solutions? Best Regards Rafał Kita

Isisombululo esikhethiwe

Hiii.....

please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser.

Monitor in Task Manager. Should stay below 2 gigs. If excessive then do below and monitor and change if need to...Test and go up again , go back down, it will eventually get a zone you and it can live with.

Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please.

Please let us know if this solved your issue or if need further assistance.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (4)

more options

Isisombululo Esikhethiwe

Hiii.....

please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser.

Monitor in Task Manager. Should stay below 2 gigs. If excessive then do below and monitor and change if need to...Test and go up again , go back down, it will eventually get a zone you and it can live with.

Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please.

Please let us know if this solved your issue or if need further assistance.

more options

Wow, you saved my life, thank you :D

more options

most welcome

more options

I am having the same problem, and unfortunately, there is no entry "Prevent Accessibility Services from accessing your browser." Waterfox lately has been havng the same problem, so much so that I uninstalled it and reinstalled Firefox, which seemed great at first, but then it started doing this hanging thing again.

Okulungisiwe ngu mafinokc