Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

can not load twitter on desktop ff 76 but it loads in chrome

  • 6 uphendule
  • 1 inale nkinga
  • 4 views
  • Igcine ukuphendulwa ngu bx5352

more options

can not load twitter on desktop ff 76 but it loads in chrome. I can manually type in https://twitter.com hit enter and there is nothing, just blank page & no error, nothing. I have cleared cache & cookies, no luck... Anyone have any other ideas.

Isisombululo esikhethiwe

Some extensions do not work in Private Browsing mode.

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (6)

more options

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop

Helpful?

more options

Thanks for the suggestion. Safe mode did not help, it still won't load. I can't click the shield to the left of the address bar, as it does not load the page. But would blocking trackers/scripts in a page, keep the page from loading at all?

Helpful?

more options

Here is some new information. I just tried opening a new private window and it loads there. Anyone know what that is about? Why it's not opening in my main window, but does in this new private one?

Helpful?

more options

Interesting.

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Helpful?

more options

Isisombululo Esikhethiwe

Some extensions do not work in Private Browsing mode.

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

Helpful?

more options

Thanks cor-el, that worked! I can visit the site again.

Thanks FredMcD for your help too and the added info!

Kurt

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.