Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Unable to play YouTube videos

  • 6 uphendule
  • 1 inale nkinga
  • 9 views
  • Igcine ukuphendulwa ngu CJ

more options

YouTube videos (both embeded and on website) seem to load (I can see thumbnails when I hover cursor over timeline) but will throw "An error occurred. Please try again later." when I click play.

Youtube debug info: "errorCode": "fmt.decode", "errorMessage": "An error occurred. Please try again later.", "wr": "GENERIC_WITHOUT_LINK"

This also happens in Private Browsing and Safe mode (addons disabled) in Firefox 75.0 and 76.0.1 (different user profiles) This issue does not occur in other browsers I have installed (Chromium, Iridium, Google C, and Pale Moon)

Everything was working fine a few hours ago, I have made no hardware, software or config changes.


EDIT: Just noticed the edit button, added a cropped screenshot of the issue.

Ama-screenshot ananyekiwe

Okulungisiwe ngu CJ

Isisombululo esikhethiwe

Looks like it's something done by MalwareBytes Anti Malware that causes the problem.

After the issue went away and came back a second time, again seemingly for no reason, I tried toggling protection for Firefox in MBAM's Exploit Protection security settings and restarting firefox. This consistently caused/fixed the issue.

It's definitely something about Firefox that's different from chromium-based browsers and even Pale Moon that's contributing to the issue though since those other browsers were never affected.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (6)

more options

Just noticed the Ff68 and Win10 tags on my question, this is due to anti-fingerprinting configs in my user.js I am encountering this issue on a Win8.1 desktop.

Tried an failed to replicate on a Win7 laptop running ff66.0.2 and a fresh install of 75.0

Could it be some sort of cache corruption? I had some memory intensive programs running with firefox in the background within the few hours between the issue arising.

I hope to resolve this without needing to reinstall or wipe my current firefox configs.

Helpful?

more options

Found a relatively recent forum thread about this issue https://www.wilderssecurity.com/threads/firefox-youtube.427636/ I installed Malwarebytes Anti Malware a week ago, that may be causing the problem.

Helpful?

more options

Hi CJ,

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

  • Click the menu button and select Options (Windows) or Preferences (Mac, Linux).
  • Select the Advanced panel and the General tab.
  • Uncheck Use hardware acceleration when available.
  • Close Firefox completely and then restart Firefox to see if the problem persists.

In Firefox 55 and above:Click the menu button and select Options (Windows) or Preferences (Mac, Linux).

  • Select the General panel.
  • Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
  • Uncheck Use hardware acceleration when available.
  • Close Firefox completely and then restart Firefox to see if the problem persists.

Did this fix your problems? Please report back to us!

Okulungisiwe ngu Shashank Shekhar

Helpful?

more options

Well the issue has been resolved but I'm not sure why.

Assuming it was cache or memory problem I cleared my temp folder. I did not uninstall or disable MBAM, only made it check for updates.

Youtube videos work again now after the third cold boot since first discovering this issue. I'll run memtest when I find the time, hopefully it's not a hardware problem.

@Shekhar As mentioned in the OP I ran Firefox in safe mode which also disables hardware acceleration. My second post clarifies that I am not using Firefox version 68, rather versions 75 and 76, none of which are 54 or below.

Helpful?

more options

The issue has resurfaced. Considering only Firefox seems to be malfunctioning I am ruling out hardware problems. Guess I'll just have to just use another browser

Helpful?

more options

Isisombululo Esikhethiwe

Looks like it's something done by MalwareBytes Anti Malware that causes the problem.

After the issue went away and came back a second time, again seemingly for no reason, I tried toggling protection for Firefox in MBAM's Exploit Protection security settings and restarting firefox. This consistently caused/fixed the issue.

It's definitely something about Firefox that's different from chromium-based browsers and even Pale Moon that's contributing to the issue though since those other browsers were never affected.

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.