Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Ask to save logins and passwords for websites is Greyed OUT when Firefox is set to Never Remeber History

  • 2 uphendule
  • 1 inale nkinga
  • 114 views
  • Igcine ukuphendulwa ngu s.singh.au

more options

In my Windows 10 Version of Firefox, when ever I set my HISTORY to 'Never Remember', the option to 'Ask to save logins and passwords for websites' is greyed out.

I do not think this combination is correct, as I want set my Firefox to 'Never' remember History but at the same I do want the option that If I do setup my user-id & Password on a new website, I want Firefox to prompt me to Save or Remember Password.

On the same token, If a password is changed Firefox must prompt that password is updated in Firefox. This will not be prompted if I set my HISTORY to 'Never Remember'.

The Image I am sharing is my current settings, I did not want reset it, as I then have to reload Firefox, re-do a lot of thinks, like Booksmarks etc.

My installed Firefox version is 76.0.1 (64-bit).

If there is work around let me know the solution. Hope to hear soon.

In my Windows 10 Version of Firefox, when ever I set my HISTORY to 'Never Remember', the option to 'Ask to save logins and passwords for websites' is greyed out. I do not think this combination is correct, as I want set my Firefox to 'Never' remember History but at the same I do want the option that If I do setup my user-id & Password on a new website, I want Firefox to prompt me to Save or Remember Password. On the same token, If a password is changed Firefox must prompt that password is updated in Firefox. This will not be prompted if I set my HISTORY to 'Never Remember'. The Image I am sharing is my current settings, I did not want reset it, as I then have to reload Firefox, re-do a lot of thinks, like Booksmarks etc. My installed Firefox version is 76.0.1 (64-bit). If there is work around let me know the solution. Hope to hear soon.
Ama-screenshot ananyekiwe

Isisombululo esikhethiwe

Although it doesn't really seem like this combination should disable the password saving feature, that is the way that it was designed. When you set the history to never remember, Firefox essentially treats it like a Private Browsing window.

As a workaround, you could change the history settings to custom, uncheck the Remember browsing and download history and Remember search and form history and Always use private browsing mode options, check the Clear history when Firefox closes option and set it to clear everything when Firefox closes.

That should give you the same effect as never remembering your history, but still give you the ability to save passwords in the browser.

Hope this helps.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (2)

more options

Isisombululo Esikhethiwe

Although it doesn't really seem like this combination should disable the password saving feature, that is the way that it was designed. When you set the history to never remember, Firefox essentially treats it like a Private Browsing window.

As a workaround, you could change the history settings to custom, uncheck the Remember browsing and download history and Remember search and form history and Always use private browsing mode options, check the Clear history when Firefox closes option and set it to clear everything when Firefox closes.

That should give you the same effect as never remembering your history, but still give you the ability to save passwords in the browser.

Hope this helps.

more options

Thanks Wesley... I have applied & it works.