Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Developer edition | responsive design mode | does not allow forward slash in input fields

  • 4 uphendule
  • 1 inale nkinga
  • 62 views
  • Igcine ukuphendulwa ngu cor-el

more options

I've found that input fields will not allow entering a forward slash (/) on Firefox Developer Edition (I am on 77.0b7 64bit at present; Windows 10 64-bit). It has been happening for at least a few weeks now.

This does not happen outside of responsive design mode. This does not happen on regular Firefox (I am on 76.0.1, 64 bit currently) either.

Here is my setup at present. Will provide more if asked!

add-ons: adaware ad block installed. plug-ins: openh264 video codec provided by Cisco systems inc. shockwave flash 32.0r0 widevine content decryption module provided by google inc themes: 'light' is enabled.

Anybody got any thoughts as to what may be going on?

Isisombululo esikhethiwe

I can replicate this.
The problem seems to be that Quick find consumes the forward slash and the single quote and prevents entering this in an input field.

It works if I disable this feature via about:config

  • accessibility.typeaheadfind.manual = false
Funda le mpendulo ngokuhambisana nalesi sihloko 👍 1

All Replies (4)

more options

Isisombululo Esikhethiwe

I can replicate this.
The problem seems to be that Quick find consumes the forward slash and the single quote and prevents entering this in an input field.

It works if I disable this feature via about:config

  • accessibility.typeaheadfind.manual = false
more options

I found some bug reports about this issue, so it is not the first time this occurred.

  • Bug 1317323 - Pressing / (slash) or ' (quote) in a text input toggles "Quick find" [69]
  • Bug 1322385 - User input in forms triggers typeaheadfind when RDM is active [68]

It works for me in the current Nightly build, so this could be a Firefox 77 (Beta/DE) only regression.

more options

Fantastically helpful, Cor-el. Thank you so much! At least for the nonce I have a work-around. I am sorry I was unaware of the bug reports database, or had missed how to find it, or I should have reviewed there first. Again, thank you.

more options

You're welcome. Maybe file a bug report about this regression although it looks weird that this is only seems to happen in Firefox 77.