Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Ever since I upgraded to the latest version of Firefox, I'm constantly getting the "I'm sorry we can't find that site" error message. I've cleared my cache, etc

  • 6 uphendule
  • 1 inale nkinga
  • 3 views
  • Igcine ukuphendulwa ngu enadalin

more options

Very frustrated. I do a lot of research (I'm a student) and when I attempt to access a well-know site (NY Times, for example) I get that annoying "Sorry...we can't find that site right now" message.

This never happened prior to update. I've cleared my cache/cookies, etc. and it still persists. It's tough to do research/browse the internet and to be constantly interrupted by that message. Is this an issue with the upgrade?

Thanks

Ama-screenshot ananyekiwe

All Replies (6)

more options

I'm not sure whether that screenshot is saying there is a DNS error (like, we're not sure nytimes.com has a corresponding website) or there was no response before the connection timed out.

In case your Firefox switched to DNS over HTTPS, you could check the status and turn it off to see whether that helps. More info in this article: Firefox DNS-over-HTTPS.

If that's not it, could you open the Network Monitor in the lower part of the tab -- either:

  • "3-bar" menu button > Web Developer > Network
  • (menu bar) Tools > Web Developer > Network
  • (Windows) Ctrl+Shift+e

-- then try to load the page (in that same tab). Does Firefox show the connection attempt and any status code?

more options

Also try; Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

You can also try the DNS Lookup tool via the about:networking page.

You can open "about:" pages via the location/address bar

  • "about:" is a protocol to access special pages
more options

@Fred: It didn't offer the option to start in safe mode...

more options

@cor-el: I have no idea what you are referring to. I'm not well-versed in DNS, etc. I'll just use another browser. This seems to be an ongoing problem with Firefox. Back to Safari I go!

more options

@jscher: thank you for your detailed walk-thru! Most appreciated. DNS over HTTPS was disabled. I tried re-loading the page with the steps outlined above and no status code message. Very frustrating because I liked the stability and security of FF, but don't have the time or patience to deal with it in its current state.

Thank you for your help...most appreciated.