Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

How do I disable the auto-active url bar on a new tab?

  • 4 uphendule
  • 1 inale nkinga
  • Igcine ukuphendulwa ngu John

more options

The title may come off confusing, let me explain. I have an `autocongif.js` and `autoconfig.cfg` script that run at startup, using a custom home page and new tab page. The example I am using is the Tilde Enhanced start page. What's unique about this, is when the webpage is active, I can start typing and search DuckDuckGo after I press enter. There are other features too. Now, when I use the homepage, the "search/url bar" in FireFox is not active. However, in a new tab, the custom url loads but the search/url bar is active, and I can't use the web pages custom search feature.

Is it possible, (I know it is, Tabliss add-on does this, but fills in a link in the search bar in it's place, which I don't I just want the URL/search bar to not be active on a new tab. Is there any way to disable this?

All Replies (4)

more options

Hi, Go to about:config via your Address Bar. Press the button saying you'll be careful. Search for browser.newtab.url. Right click -> Reset. You might also want to check for any prefs Trovi has set. Search for trovi and reset all prefs (Right click -> Reset) You might have to restart Firefox for this to work.

Thank you.

more options

Hello, I tried what you said, chamodie1996, and I didn't see my desired results. The Search/URL bar was still outlined with a blue shadow/border and when I began typing, characters appeared inside the URL bar, which is not what I wanted.

more options

Hi John, I think I replied to your Reddit thread on this the other day.

Firefox always puts the cursor in the address bar on the new tab page.

Extensions that replace the new tab page like appear to have a workaround, but you mentioned that you don't like having the page address in the address bar so you can't take advantage of that.

Hopefully I've caught this thread up and someone will have a new suggestion from here.

more options

I did not get any more help there. I was hoping to not display any data in the URL bar. I am wondering if this can be solved via userconfig.js or something. Let me know if there are any other ideas of what to do.