Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Firefox crashes more than 50 times a day, what should I do?

more options

I've been experiencing too much crashes on Firefox 75.0, downloaded from Mozilla, not the one that comes with Linux. I'm running on debian9 on Qubes OS but I also experienced crashes on Ubuntu 19.

It happens mainly when I switch tabs. I'm asked to restart. I already submitted hundreads of crash reports, hope you guys are taking a look. However this have been happening since january I guess. And it's getting worse.

Sometimes the crash will happen again and again if I try to reload the tab. I have to close the tab and open it again so it won't crash.

Please help, I love firefox, don't want to use another browser.

Here are a few ones:

https://crash-stats.mozilla.org/report/index/1859a0a1-2a41-4381-b2f9-8dd3d0200415 https://crash-stats.mozilla.org/report/index/35fb2b8d-f773-4c81-85cc-a1b560200415 https://crash-stats.mozilla.org/report/index/f81599e5-8671-45b4-8935-b42970200411 https://crash-stats.mozilla.org/report/index/01ca9596-1fac-4927-a61f-b736b0200219

All Replies (6)

more options

Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.

https://www.mozilla.org/en-US/firefox/all/

Helpful?

more options

FredMcD Top 10 Contributor said

Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution. https://www.mozilla.org/en-US/firefox/all/

im already using this version

Helpful?

more options

Hi, go to the firefox menu ≡ > options > privacy & security panel and under permissions check the setting to prevent accessibility services from accessing your browser.

Thank you.

Helpful?

more options

chamodie1996 said

Hi, go to the firefox menu ≡ > options > privacy & security panel and under permissions check the setting to prevent accessibility services from accessing your browser. Thank you.

wont help either

Helpful?

more options

Hii

  • Bulleted list itemyou may have already run this if not, try Firefox in safe mode On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • When the Firefox Safe Mode window appears, select "Start in Safe Mode"
  • IF FIREFOX DOESN'T CRASH THAT MEANS ITS A PROBLEMS WITH EXTENSIONS,THEMES OR HARDWARE ACCELERATION TRY DISABLING THEM

Helpful?

more options

HI Lucas Zanella:

I see you filed a bug, thanks!

https://bugzilla.mozilla.org/show_bug.cgi?id=1631680

Did you try Firefox safe mode? I assume you did but just in case:

https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode#firefox:linux:fx75

Anyhow I would also suggest you post any other troubleshooting information like the contents of about:support. And of course run a malware check on your Linux computer and check out your hardware.

Cheers!

...Roland

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.