Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

facebook pages turn black after a second, browser tab is underlined

  • 6 uphendule
  • 1 inale nkinga
  • 18 views
  • Igcine ukuphendulwa ngu Arden Buck

more options

facebook pages turn black after a second, browser tab is underlined. Only in Firefox. Does anyone know what this is about?

Isisombululo esikhethiwe

Thank you for the response. I looked, and find that I don't have Facebook container.

It seems to be a problem on only my computer. On my wife's computer Facebook comes up fine.

I don't normally participate in Facebook so I'm not a "member." Would that make a difference?

Thank you.

Arden

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (6)

more options

The underline could indicate the page is in a specific container. Do you use the Facebook Container extension to isolate Facebook from the rest of your browsing? You could try temporarily disabling that extension and using Facebook in a private window (or regular window) instead to see whether that works better.

You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then scan down the list on the right side. To disable an extension, click its "slider switch" icon. After a few moments, it should drop down to the disabled extensions list and disappear from your toolbar.

To reverse that later if it doesn't help, scroll down to it and click the slider switch again to re-enable it.

Did that all make any difference?

Helpful?

more options

Isisombululo Esikhethiwe

Thank you for the response. I looked, and find that I don't have Facebook container.

It seems to be a problem on only my computer. On my wife's computer Facebook comes up fine.

I don't normally participate in Facebook so I'm not a "member." Would that make a difference?

Thank you.

Arden

Helpful?

more options

Arden Buck Question owner said

I don't normally participate in Facebook so I'm not a "member." Would that make a difference?

Hi Arden, Facebook will hide some content from users who are not signed in, but more often, you get a notice to that effect, either an overlay suggesting your log in, or a redirect to a login page. I don't think it's normal to get a plain black screen.

Do you use any extensions to remove ads? Sometimes they remove overlays and leave opaque layers that block the content making it hard to figure out what is wrong with a page. Their toolbar buttons often provide features to make an exception for the page to see it as it was meant to display.

Helpful?

more options

I have adblock plus, but I disabled it and it still turns black after 1-2 seconds. Not just part, but the entire active screen.

Arden

Helpful?

more options

Arden Buck said

I have adblock plus, but I disabled it and it still turns black after 1-2 seconds. Not just part, but the entire active screen.

Hi Arden, when you say the entire active screen, do you mean outside of the page area, including the toolbar area? That sounds like "full screen" and usually could be canceled by pressing the Esc key.

Could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Helpful?

more options

That did it! I opened in safe mode, and opened Facebook. It went black for a moment and then went on normally. I restarted adblock and restarted Firefox in normal mode, and Facebook came on normally.

Thank you so much for the help! I really appreciate it.

Arden Nederland, CO

Helpful?

Buza umbuzo

Kufanele ulogele ukungena ku-akhawunti yakho ukuze uphendule amaphosti. Uyacelwauqale umbuzo omusha, uma ungekabi nayo i-akhawunti namanje.